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1
Welcome to SOLIDWORKS 2024

This chapter includes the following topics:

• Top Enhancements
• Performance
• For More Information

At SOLIDWORKS®, we know that you create great designs, and that your great designs get
built. To streamline and accelerate your product development process from concept through
manufactured products, SOLIDWORKS 2024 contains new, user-driven enhancements focused
on:

• Working Smarter. Reduce your workload in SOLIDWORKS with the ability to defeature
models more efficiently, add part features to assemblies by first associatively inserting an
assembly into a part, and include unit of measure as a custom property in your notes and
tables.

• Working Faster. Work more efficiently in SOLIDWORKS with intelligent, instant creation
of sketch dimensions, improvements to collinear dimensioning for chain dimensions in
drawings, and access to new components in Toolbox.

• Working Together. SOLIDWORKS is better together with your friends! Empower others
across product development disciplines with enhancements to SOLIDWORKS products
including PDM, Simulation, Electrical, Visualize, MBD, Composer, and more. Best yet,
SOLIDWORKS now includes access to the 3DEXPERIENCE® platform.
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Top Enhancements
The top enhancements for SOLIDWORKS® 2024 provide improvements to existing products
and innovative new functionality.

Parts and Features
on page 24

• Hole Wizard

• Making Multibody Parts from Assemblies

Sheet Metal on
page 32

• Slot Propagation
• Stamp Tool
• Tab and Slot

Structure System
and Weldments on
page 39

• Corner Management

Assemblies on page
45

• Defeature Rule Sets
• Repairing Missing References in a Linear or Circular Pattern

Detailing and
Drawings on page
58

• Overridden Dimensions
• Keeping Chain Dimensions Collinear
• Reattaching Dangling Dimensions

SOLIDWORKSMBD
on page 129

• Hole Tables
• Repairing Dangling Dimensions

Performance
SOLIDWORKS® 2024 improves the performance of specific tools and workflows.

Some of the highlights for performance and workflow improvements are:

SOLIDWORKS Fundamentals
• Graphics rebuild after exiting SOLIDWORKS options.

SOLIDWORKS checks the changed options when you click OK to exit the Options dialog
box. SOLIDWORKS only performs a graphics rebuild on the active document if the
changed options require it. In earlier releases, SOLIDWORKS always performed a
graphics rebuild on the active document.

• Silhouette edges.

You can enable the GPU hardware to improve the display of silhouette edges in HLR,
HLV, and wireframe views.

9
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In Tools > Options > System Options > Performance, select Hardware
accelerated silhouette edges.

Sketching
Equal relations solve more efficiently which improves 3D sketch performance.

Sheet Metal
When rebuilding complex sheet metal parts with large numbers of sketched bends or
jogs, rebuild time is improved by up to 50%.

Import/Export
The performance of importing STEP, IGES, and IFC assemblies as multibody parts is
improved up to 30%.

SOLIDWORKS PDM
SOLIDWORKS PDM 2024 has improved the performance of file-based operations.

The following operations are approximately two times faster:

• Add files
• Change state
• Copy tree

The copy tree to compressed archive operation is orders of magnitude faster.

SOLIDWORKS Electrical
Archiving a project for remote users (VPN connection) is improved and is much faster.

eDrawings
Performance improvements include:

• Measure tool. Up to 20 times faster when opening the Measure pane, entity selection,
and changing units.

• Markup tool. Up to 10 times faster when creating markups.
• Reset tool. Up to 1.5 times faster when resetting a model.
• Faster rendering and printing with software OpenGL.
• Faster times for closing files.

For More Information
Use the following resources to learn about SOLIDWORKS:

This guide is available in PDF and HTML formats. Click:What's New in PDF
and HTML

• > What's New > PDF

10
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• > What's New > HTML

In SOLIDWORKS, appears next to new menu items and the
titles of new or significantly changed PropertyManagers. Click

Interactive What's
New

to display the topic in this guide that describes the
enhancement.

To enable Interactive What's New, click > What's New >
Interactive.

Contains complete coverage of our products, including details
about the user interface and examples.

Online Help

Contains posts from the SOLIDWORKS user community on the
3DEXPERIENCE® platform (login required).

SOLIDWORKS User
Forum

Provides information about late changes to our products,
including changes to the What's New book, online help, and
other documentation.

Release Notes

SOLIDWORKS Legal Notices are available online.Legal Notices
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2
Installation

This chapter includes the following topics:

• Installation Access Starting with SP0 for SOLIDWORKS Student and Education
Editions

• Render Installation Manager with Microsoft Edge WebView 2

Installation Access Starting with SP0 for SOLIDWORKSStudent and Education
Editions

Users with Student and Education licenses can install SOLIDWORKS version 2024 starting
with SP0. Previously, these users could not access SOLIDWORKS until SP2.

Render Installation Manager with Microsoft Edge WebView 2
The SOLIDWORKS Installation Manager uses Microsoft Edge WebView2 to render the
Installation Manager pages. WebView2 installs if not found on your machine.

Previously, the Installation Manager pages were rendered with Microsoft Internet Explorer.
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3
SOLIDWORKS Fundamentals

This chapter includes the following topics:

• Changes to System Options and Document Properties
• Accelerate the Display of Silhouette Edges
• Application Programming Interface
• Saving SOLIDWORKS Documents as Previous Versions

Changes to System Options and Document Properties
The following options have been added, changed, or removed in the software.

System Options

AccessDescriptionOption

AssembliesDefines default values for Add Prefix
and Add Suffix when creating
opposite-hand components.

Opposite hand mirror
components

AssembliesDefines a default prefix for virtual
components that are created from
external files.

Prefix for virtual
components created from
external files

DisplayControls the visibility of dimensions.Display DimXpert
dimensions on top of
model

ColorsSpecifies a color for overridden
dimensions.

Drawings, Overridden
dimensions

PerformanceEnables the GPU hardware to improve
the display of silhouette edges in HLR,
HLV, and wireframe view modes.

Hardware accelerated
silhouette edges

SketchTurns on sketch dimension previews.Preview sketch
dimensionwhen selected
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AccessDescriptionOption

Drawings >
Performance

Opens a drawing by default in Detailing
mode.

Always open a drawing
in detailing mode

File LocationsUnder Show folders for, specifies a
location for defeature rule sets,
*.slddrs, and related log files.

Defeature Rule Sets

Document Properties

AccessDescriptionOption

Annotations >
Geometric
Tolerances

Specifies a value for the Decimal
Separator. Options are Comma or
Period.

Decimal Separator

DetailingHighlights the associated elements of a
dimension.

Highlight associated
elements of dimension
selection

Dimensions >
Linear

Places dimension text that cannot fit
within the extension lines outside of the
extension lines on an extended
dimension line.

Offset text automatically
when space is limited

Dimensions >
Linear

Specifies arrowhead replacements when
arrowheads overlap. Options are Points
or Oblique Strokes.

When arrowhead
overlaps substitute
arrowhead termination
automatically with:

Drafting
Standard >
Tables

(Available for parts only). Specifies the
options for hole tables in the active
document.

Hole

DimensionsDisplays the color of overridden
dimensions.

Highlight overridden
dimensions in a different
color

14
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Accelerate the Display of Silhouette Edges

You can enable the GPU hardware to improve the display of silhouette edges in HLR, HLV,
and wireframe views.

In Tools > Options > System Options > Performance, select Hardware accelerated
silhouette edges.

Application Programming Interface
See SOLIDWORKS API Help: Release Notes for late-breaking updates.

• Access the configuration-specific custom PropertyManagers of cut lists and assembly
components

• Retrieve errors that occurred during the last call to IFeatureManager::CreateFeature
• Use the option, Exclude parent surface, to exclude the parent surface from the

Surface-Untrim feature result
• Insert bills of materials (BOMs) in parts, assemblies, and drawings with detailed cut
lists and specify whether to dissolve components in indented BOMs

• Get and set whether to display dual unit values in dimension range lengths of geometric
tolerance symbols

• Get and set the decimal separator type for geometric tolerance symbols
• Get the diameter of a model's spherical bounding box

15
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Saving SOLIDWORKS Documents as Previous Versions

Beginning with SOLIDWORKS 2024, you can save SOLIDWORKS parts, assemblies, and
drawings created or saved in the latest version of SOLIDWORKS as fully functional
documents in a previous version of SOLIDWORKS. You can save documents back to the
previous two releases. Pack and Go also supports this functionality.

You can save SOLIDWORKS 2024 files as SOLIDWORKS 2023 or SOLIDWORKS 2022
versions. This previous release compatibility lets you share files with others who use one
of the two previous versions of SOLIDWORKS. You cannot extend the previous release
compatibility beyond those two releases.

SOLIDWORKS users must have an active subscription license to access this functionality.
3DEXPERIENCE users are active subscribers by default.

Workflow

You must manually address incompatible items in this process. Incompatible items, as
described in the table below, are items that do not exist or are not supported in the
selected previous release.

Recommendation: Addressing incompatible items might significantly change a model.
Save a copy of the current model and address incompatible items in that copy before
saving it as a previous version.

To save a SOLIDWORKS document as a previous version:

1. Open or save a SOLIDWORKS document in the latest version of SOLIDWORKS.
2. Click File > Save As.
3. In the dialog box, for Save as type, select the previous version to which to save the

document and click Save.
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If the document contains Incompatible Items or Other Items as described below, the
Previous Release Check dialog box appears. Otherwise, the software saves the
document as the previous version.

To open this dialog box at any time, click Tools > Evaluate > Previous Release

Check .

DescriptionTab

Lists items that you must manually
address before you can save the file as a
previous version of SOLIDWORKS. If you
remove or edit the incompatible items, it
might change the mass properties, size,
shape, or rebuild behavior of the model.
In some instances, you must delete the
incompatible item. In other instances,
changing a feature option might address
the incompatible item. The list of
incompatible items is in the order that
they first appear in the FeatureManager
design tree.

Incompatible Items

Lists items that the software will
automatically remove in the save process.
These are items that do not impact the
rebuild, mass properties, or topology of
the document, such as display items like
annotations or information on drawings.

Other Items

17
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If the document contains only Other Items and no Incompatible Items, on the Other
Items tab, click ProceedWith Save to save the document to the previous version.

After you address all the Incompatible Items, a message confirms that the document
is fully compatible with the selected previous release.

4. Repeat the save process to save the file as the previous version.

18
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4
User Interface

This chapter includes the following topics:

• Hide and Show
• Usability
• Icon Updates for Open, Save, and Properties Commands

Hide and Show

When you multiselect bodies, planes, or sketches that have a combination of shown and
hidden states in the FeatureManager® design tree, the context toolbar shows both the

Hide and Show tools. You can click Hide or Show to change the visibility state of
all the selected entities.

The Hide and Show tools also appear when you multiselect a combination of hidden and

shown planes and sketches. The Show Hidden Bodies tool is added to the Tools >
Customize > Commands > Features tab so you can add it to toolbars and the

CommandManager. You can use the Search tool or the S key to find Show Hidden

Bodies and Show Hidden Components .
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Usability
The user interface is enhanced to improve productivity.

Coordinate
System to Save

In the Save As dialog box, you can choose which coordinate system
to save with a file. In the dialog box, in Output Coordinate System,
specify the coordinate system to save. When you open the file, the
new coordinate system is the origin.

Opening
SOLIDWORKS
Files from
Shortcuts

You can drop a shortcut to a SOLIDWORKS file directly from a local
drive into SOLIDWORKS to open the file.

Selecting
Materials

In the Material dialog box, you can double-click a material to
automatically apply the material to the model and close the dialog
box. You can still click Apply to review the material properties before
applying the material.

Icon Updates for Open, Save, and Properties Commands
Tool icons are updated for Open, Save, and Properties commands for SOLIDWORKS and
SOLIDWORKS 3DEXPERIENCE apps.

Change20242023Tool

Arrow colorOpen

Arrow colorOpen Drawing

Removed label lines
and modernized

Save

20
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Change20242023Tool

Removed label lines
and moved pencil

Save As

Removed label lines
and modernized

Save All

New icon with cloudSave to
3DEXPERIENCE
(3DEXPERIENCE
users only)

Removed label lines
and modernized

Save to This PC
(3DEXPERIENCE
users only)

Removed label lines
and modernized

Older Version File

New icon to
distinguish it from
standard Properties
icon

PLM Properties
(3DEXPERIENCE
users only)

21

User Interface



5
Sketching

This chapter includes the following topics:

• Sketch Blocks
• Sketch Dimension Previews

Sketch Blocks

In the FeatureManager® design tree, you can hide and show individual blocks in sketches.
You can also see whether a block is under defined (-), over defined (+), or fully defined.

To hide and show individual blocks in sketches, right-click the sketch block in the
FeatureManager design tree and click Hide or Show.
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Sketch Dimension Previews

You can preview sketch dimensions when you select a sketch entity.

You can select the dimension to edit it. When you click anywhere else in the graphics
area, the preview dimension disappears.

To turn on sketch dimension previews, click Tools > Options > System Options >
Sketch and select Preview sketch dimension when selected.

To change the dimension preview color, click Tools > Options > System Options >
Colors. Under Color scheme settings, edit the color for Dimensions, Preview.

Sketch dimension previews are not supported for path lengths.

23
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6
Parts and Features

This chapter includes the following topics:

• Hole Wizard
• Making Multibody Parts from Assemblies
• Body Transparency for Combine Features
• Cylindrical Bounding Boxes
• Excluding Parent Surfaces in Untrim Features
• Flip Side to Cut for Cut Revolves
• SelectionManager for Projected Curves
• Stud Wizard
• Symmetrical Linear Patterns

Hole Wizard

Sketching with the Hole Wizard is enhanced when you use the Positions tab of the
PropertyManager.

Under Hole Positions, you can click Existing 2D Sketch and select an existing 2D
sketch to position and automatically create the holes at all endpoints, vertices, and points
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of the sketch geometry. You can select sketch entities like lines, rectangles, slots, and
splines. Sketch Options specify the geometry used to automatically create the instances.

Under Sketch Options, there are two options:

• Create instances on sketch geometry (Enabled by default). Positions holes at all
endpoints, vertices, and points of the sketch geometry.

• Create instances on construction geometry. Positions holes at all endpoints,
vertices, and points of the construction geometry.

You can skip hole instances. Under Instances to Skip , select hole instances to skip
in the graphics area.

When you delete a Hole Wizard feature, you can retain the hole position sketch. In the
Confirm Delete dialog box, clear the Delete absorbed features option to delete only
the hole profile sketch and keep the hole position sketch. To delete the hole position
sketch, select Delete absorbed features.

25
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Making Multibody Parts from Assemblies

The Make Multibody Part tool converts an entire assembly into a separate, single
multibody part that is linked to the parent assembly.

The parent assembly reflects all features that you create in the linked multibody part.
Downstream platform applications also support these features so you can perform
post-assembly operations on the multibody part, such as material removal.

To create a multibody part, in an assembly, click Tools > Make Multibody Part.

The Make Multibody Part feature appears in the FeatureManager® design tree. Solid
bodies are transferred by default. You can decide which other assembly entities to transfer
such as surface bodies, reference geometry, and materials. Under the Make Multibody
Part feature, the tool groups the entities into folders that show the number of instances.

All the bodies in the multibody part inherit their names from the assembly. They also
match the position of the parts relative to the origin in the parent assembly. You can
choose the configuration to create the multibody part.

26
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Body Transparency for Combine Features

In the Combine PropertyManager, for the Subtract operation, you can make the main
body transparent. This helps you select smaller bodies that are completely immersed
inside the main body.

Click Insert > Features > Combine. In the PropertyManager, under Operation Type,
select Subtract and under Main Body, select Make main body transparent.

Cylindrical Bounding Boxes

27
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You can create cylindrical bounding boxes that are useful for bodies with cylindrical
geometry such as rotational, circular, or turned parts. SOLIDWORKS® captures the
bounding box parameters and records them in the Custom Properties dialog box.

Click Insert > Reference Geometry > Bounding Box. In the PropertyManager, under
Type of Bounding Box, select Cylindrical. SOLIDWORKS generates the smallest
cylindrical bounding box that fits the model.

Excluding Parent Surfaces in Untrim Features

You can exclude the parent surface from the results of Surface-Untrim features. In the
Untrim Surface PropertyManager, under Options, select Exclude parent surface to
exclude the parent surface from the Surface-Untrim feature results.

To view the Surface-Untrim feature, hide the parent surface. This option simplifies the
control of the untrimmed surfaces. In earlier releases, you had to use multiple tools to
achieve the required results.

28
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Flip Side to Cut for Cut Revolves

You can flip the side to cut for cut-revolve features, similar to cut-extrude features. This
retains the inner portion of a sketch and discards the region outside the sketch.

In the Cut-Revolve PropertyManager, under Direction 1, select Flip side to cut. In
earlier releases, this option did not exist and required extra steps to achieve the required
results.

SelectionManager for Projected Curves
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In the Projected Curve PropertyManager or if you right-click in the graphics area, you
can use the SelectionManager to select portions of sketches to create projected curves.

To access the Projected Curve PropertyManager, click Insert > Curve > Projected.

With the SelectionManager, you can select only one continuous group of entities. You
cannot select multiple disconnected entities.

In earlier releases, the SelectionManager was not available and you could project only
the entire sketch.

Stud Wizard

You can apply a StudWizard feature to a shaft that has the same diameter as the thread.
You can modify the size of Stud Wizard features created in previous versions of
SOLIDWORKS so the thread diameter matches the shaft diameter.

The software supports this functionality for studs created on a cylindrical body or surface.
In earlier releases, the thread diameter had to be smaller than the shaft diameter.
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Symmetrical Linear Patterns

You can create symmetrical linear patterns from a seed feature. The linear pattern uses
the parameters from Direction 1 to create a symmetrical linear pattern in Direction 2.

In the Linear Pattern PropertyManager, under Direction 2, click Symmetric to create a
symmetrical linear pattern using the Direction 1 parameters.
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7
Sheet Metal

This chapter includes the following topics:

• Rip Tool
• Slot Propagation
• Stamp Tool
• Normal Cut in Tab and Slot

Rip Tool

You can use the Rip tool to create rips in hollow or thin-walled cylindrical and conical
bodies. By selecting an edge on a cylindrical or conical face, you can flatten the part as
sheet metal.

In earlier releases, if you had a cylindrical or conical part, you had to create an intentional
gap in the base sketch to convert the part to sheet metal.

SOLIDWORKS supports straight cuts only, not slanted cuts.

To use the rip tool in a cylindrical part:

1. In a hollow or thin-walled cylindrical or conical part, click Rip (Sheet Metal toolbar).
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2. In the graphics area, select:

a. An edge.

b. A reference point on the model.

The reference point can be on the model or anywhere in the graphics area. If you
select a reference point that is not on the model, the software projects the point
onto the model.

3. Specify options in the PropertyManager and click .
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With the rip completed, you can convert the part to sheet metal using the Insert
Bends tool.

Slot Propagation

When creating a tab and slot feature in an assembly component, you can propagate the
slots to other instances of the same component in the assembly.

If an assembly has a component with a tab previously created with the Tab and Slot
tool, you can propagate slots for that tab to other instances of the component in the
assembly as well.

For example, if you have an assembly with multiple instances of a part with a tab, you
can propagate slots for the corresponding instances.

Slots propagate only when the tab component intersects with the slot component.

If you pattern or mirror a component with a tab, you can select Propagate Slots in the
PropertyManager to apply slots to intersecting components in the assembly.

To use slot propagation for assemblies when creating tab and slot features:

1. In an assembly, click Tab and Slot (Sheet metal toolbar).
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2. In the graphics area, select an edge for the tabs and a corresponding face for the
slots.

3. Specify options in the PropertyManager.

If SOLIDWORKS detects multiple instances of the component in the assembly, you
can specify options under Propagate Slots:

• Only selected. Propagates slots to the selected component only.
• All instances in same parent assembly. Propagates slots to all instances of the
selected component that are in the same parent assembly.

• All instances. Propagates slots to all instances of the selected component.

4. Click .

To use slot propagation for assemblies with existing tab and slot features:

1. In an assembly with a component that has a tab and slot, right-click the component
and click Propagate Slots.

2. In the Slot Propagation PropertyManager, under Instances for slot propagation,
specify an option:

• Only selected. Propagates slots to the selected component only.
• All instances in same parent assembly. Propagates slots to all instances of the
selected component that are in the same parent assembly.

• All instances. Propagates slots to all instances of the selected component.

3. Click .

Slot Propagation PropertyManager

To open this PropertyManager:

1. In an assembly with a component that has a tab and slot, right-click the component
and click Propagate Slots.

Selection

Lists the components to apply the slots to.Propagate slots for
these component(s)

Specifies which components to propagate slots to:
• Only selected. Propagates slots to the selected
components. With this option, you can delete specific
components from the list.

• All instances in the same parent assembly. Propagates
slots to all instances of the selected components that are in
the same parent assembly.

• All instances. Propagates slots to all instances of the
selected components. With this option, if some components
already have a slot, they are ignored.

Instances for slot
propagation
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Stamp Tool

You can use the Stamp tool to create sketch-based parametric forming tools to apply to
sheet metal parts. With sketch-based forming tools, you can create a sketch with a few
parameters to stamp or form the sheet metal.

In earlier releases, you had to define all sketches and features, save the forming tool as
a part (.SLDFTP), then apply it to sheet metal.

Using sketches to create forming tools is a faster way to apply forming tools to sheet
metal parts. The Stamp tool allows more flexibility to experiment with different designs
and parameters.

Using the Stamp Tool

To use the stamp tool:

1. In a sheet metal part, click Stamp (Sheet metal toolbar) or Insert > Sheet
Metal > Stamp.
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2. Sketch a closed profile sketch on the part for the stamp shape.

3. In the PropertyManager, specify options and click .

Stamp PropertyManager

To open this PropertyManager:

1. In a sheet metal part, click Stamp (Sheet metal toolbar) or Insert > Sheet Metal
> Stamp.

Stamp Parameters

Specifies the stamp depth from the top or bottom of the
sheet metal face.

Depth

Reverses the direction of the stamp.Reverse Direction

Specifies the taper angle to apply to the stamp side faces.Draft Angle

Fillet
If you specify a radius in the sketch before creating a stamp, the sketch radius is prioritized
when creating the stamp.
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Specifies the radius created by the die.Die Radius (R1)1

Specifies the radius created by the punch.Punch Radius (R2)2

Adds a corner punch radius.

Specify the Radius created by the corner
punch.

Punch Side Corner
Radius

3

Normal Cut in Tab and Slot

When you use the Tab and Slot tool, you can specify that the slot is normal to the sheet
even if the tab is at an angle to the slot. Slots that are normal to are essential in the
manufacturing process.

In the Tab and Slot PropertyManager, under Slot, select Normal Cut.
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8
Structure System and Weldments

This chapter includes the following topics:

• Corner Management
• Displaying Units in File Properties
• Structure System

Corner Management

You can apply corner treatments manually or automatically.

To open the Corner Management PropertyManager:

1. Open a part and click Structure System > Primary Member.
2. Create primary members and exit the structure system mode.
3. In the PropertyManager, specify an option:

• Automatic. Groups similar corners and applies the corner treatment.
• Manual. Lets you group similar corners and apply the corner treatment.

4. Select Automatic.
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SOLIDWORKS selects a plane that determines the trim order of members. You can
then modify the base plane reference, groups, and corner treatment, if required.

5. Specify a Trim option.

6. Click Next to continue with the corner treatment.

Two Member PropertyManager

The user interface of the Two Member PropertyManager is enhanced.

Enhancements include:

• Changes to trim types and trim options under Corner Treatment. You can select one
of the following trim types:

Trim optionsTrim typeIcon

Planar Trim or Body TrimEnd Butt1

Planar Trim or Body TrimEnd Butt2

Miter Trim

First contact planar trim or Full
contact planar trim

Open Corner

• You can use the End Butt1 and End Butt2 trim options for swapping. Previously, you
could swap the tool and body to trim using the arrows .

• Updated icons:

Trim OptionIcon

Planar Trim

Body Trim

Miter Trim

• Open corner . Trims both members and creates an open corner.
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• The Trim Tool shortcut menu is available in the graphics area. It lets you swap the
member to trim.

• In the PropertyManager, for Trim Tool, you can select Automatic or User Defined.
The User Defined option lets you select a face or a plane to trim.

Complex Corner PropertyManager

The user interface of the Complex Corner PropertyManager is enhanced.

You can use Trim order for Planar Trim. Previously, you could use it only for Body
Trim.
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Editing the Corner Management Options

You can modify the corner treatment.

To edit the corner management options:

1. In the FeatureManager designTree, right-click Corner Management and click Edit
Feature.

2. In the PropertyManager, click Back .
3. Click Reset all corners to clear all corner management settings.

If you edit the structure system and add new corners, the corner management
settings apply to the new corners.

42

Structure System and Weldments



Displaying Units in File Properties

You can capture and display the units for the Text type of file properties.

To display units in file properties:

1. Click Properties (Standard toolbar).
2. In the Properties dialog box, on the Custom and Configuration Properties tabs, select

a property name.
3. For Type, select Text.
4. Click in Value/Text Expression.
5. From the Properties flyout, select a property to display the evaluated value.
6. From the Units flyout, select a unit.

In previous versions, you could not capture the units for file properties.
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Structure System

Structure system has improved usability in the graphics area and PropertyManager.

• When editing the structure system in the graphics area, you can change the length of
the point length member.

To change the length, double-click the member and click the dimensions. Previously,
you had to edit the length of the point length member from the Primary Member
PropertyManager.

• You can use corner management for profiles of less than 2mm.
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9
Assemblies

This chapter includes the following topics:

• Defeature Rule Sets
• Propagating Visual Properties in Defeature Groups
• Repairing Missing References in Linear or Circular Component Patterns
• Mate References
• Auto-Repair for Missing Mate References
• Assigning Component References to Top-Level Components
• Specifying a Prefix and Suffix for Components

Defeature Rule Sets

Using the Defeature Silhouette method, you can create a set of rules to simplify the
components in a model. You can specify criteria for component selection, defeature
method, and a defeature orientation. You can enclose the components in one body and
propagate visual properties.

For example, you can create a rule to simplify fasteners as cyclinders when the filename
for a fastener contains bolt, nut, or washer.
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You can save the rule set to use with other models. You can specify a file location for
saved rule sets. You can use a rule set with a defeature group to defeature a model.

Specifying a File Location for Defeature Rule Sets

You can save defeature rule sets and log files to a designated folder.

You can use a saved defeature rule set with a different model. A log file shows the outcome
of applying a defeature rule set to a model. The log file includes a list of components with
a status of OK or Failed.

To specify a file location for defeature rule sets:

1. Click Tools > Options > System Options > File Locations.
2. Under Show folders for, select Defeature Rule Sets.
3. Click Add and select a location.

Creating Defeature Rule Sets

You can use a defeature rule set to simplify your model.

To create a defeature rule set:

1. Open a model, and click Defeature (Tools toolbar) or Tools > Defeature.

2. In the PropertyManager, select Silhouette .

3. Click Next .
4. Under Apply Defeature Rules to Assembly, click Edit Rules.
5. In the Defeature Rules Editor dialog box, under Name, enter a name.

6. Under Selection Criteria, click Define selection criteria.
7. In the Advanced Component Selection dialog box, select search criteria.

For example, search for fasteners where the filename contains bolt.

8. In the Defeature Rules Editor dialog box, specify the Defeature Type and Defeature
Orientation.
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For each rule, Name, Selection Criteria, Defeature Type, and Defeature
Orientation must be populated.

9. Optional: Click Save to save the rules as a defeature rule set, .slddrs.
10. In the Defeature Rules Editor dialog box, click OK to return to the PropertyManager.

Under Apply Defeature Rules to Assembly, the rule status is Pending.

11. Click Apply.

After SOLIDWORKS® applies the rule to the model, the status changes to Done (x
of y bodies OK).

12. Optional: Click Save log to save the results to a log file.

When you open the log file, you see a list of the defeatured components and the
defeatured status.

Log for defeature silhouette rules applied to C:\Lifts\LIFT.SLDASM

### Rule: Fasteners - bolts ###
Hex@12mm NOM x 70mm LG, METRIC SHOULDER BOLT-3@4545: OK
Hex@12mm NOM x 70mm LG, METRIC SHOULDER BOLT-2@4545: OK
Hex@12mm NOM x 70mm LG, METRIC SHOULDER BOLT-1@4545: OK
Hex@12mm NOM x 70mm LG, METRIC SHOULDER BOLT-2@4568: OK
Hex@12mm NOM x 70mm LG, METRIC SHOULDER BOLT-3@4568: OK
Hex@12mm NOM x 70mm LG, METRIC SHOULDER BOLT-1@4568: OK
Rule complete: 6 OK, 0 Failed

Defeature - Apply Defeature Rule Sets PropertyManager

In assemblies, you can create a defeature rule set to simplify a model.

You can use a rule set with a defeature group to defeature a model.

To open the Defeature - Apply Defeature Rule Sets PropertyManager:

1. Open a model and click Defeature (Tools toolbar) or Tools > Defeature.
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2. In the PropertyManager, select Silhouette .

3. Click Next until the Apply Defeature Rule Sets page appears.

Defeature Rule Sets

Specifies the rule set to load.
None displays when there are no loaded rule sets. Saved
rule sets display in the list.

To specify the file location for the saved rule set, click
Tools > Options > SystemOptions > File Locations.
Under Show folders for, select Defeature Rule Sets.
Click Add to specify a location.

Load a saved Defeature
Rule Set

Apply Defeature Rules to Assembly

Lists the rules.Rule

Displays the results of applying the rule:

• Pending. Displays when the rule is not applied or when an
existing rule is modified but not reapplied.

• Done (x of y bodies OK). After applying the rule, displays the
number of components processed, x, and the number of
components, y that meet the criteria.

Status

Applies all rules to the model in the order that the rules are listed.
The defeatured geometry generates and a preview displays in the
graphics area.
After a rule is applied to a component, no other rules are applied
to that component.

After saving the model as a part, the defeature components display
in the FeatureManager design tree.

The log file includes a list of components with a status of OK where
components are defeatured or Failed where components are not
defeatured.

Rules apply to part level components. Rules do not apply to
subassemblies.

Apply

Removes all the rules and deletes the simplified geometry applied
to the model.

Clear

Opens the Defeature Rules Editor dialog box.Edit Rules

Saves the log file.Save log
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Defeature Rules Editor Dialog Box

You can create a set of rules to automatically simplify the components in a model.

To open the Defeature Rules Editor dialog box:

1. Open a model and click Defeature (Tools toolbar) or Tools > Defeature.

2. In the PropertyManager, select Silhouette .

3. Click Next until the Apply Defeature Rule Sets page appears.
4. Under Apply Defeature Rules to Assembly, click Edit Rules.

Creates a new rule set.New

Opens an existing rule set.Open

Saves the rule set in a Defeature Rule Set file, .slddrs.Save

Specifies a name for the rule set.Name

Displays the selection criteria.
For a new rule, click Define selection criteria to open
the Advanced Component Selection dialog box where
you define the selection rules.

To modify a rule, click the selection criteria for the rule.
Under Rule Definition, click Selection Criteria.

In the Advanced Component Selection dialog box, the
following functionality is not available when you open
the dialog box from the Defeature PropertyManager:

• Manage Searches tab
• Name of Search
• Apply

Selection Criteria
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Specifies a simplification method:
Creates a cuboid bounding box.Bounding Box

Creates a cylinder derived from the
dimensions of a cuboid bounding
box.

Cylinder

Creates an extruded polygon that
fits around the outline of the
selected bodies and components.

Polygon
Outline

Creates an extruded body by using
the outlines of the selected bodies
and components.

Tight Fit
Outline

Creates an exact copy of the
selected bodies and components.

None (Copy
Geometry)

Defeature Type

Creates a single body that includes the specified
components.
• Off
• Per part
• Entire group

When you select Cylinder or None (Copy
Geometry) for Defeature Type, Enclose in one
body is set to Off.

Enclose in one
body

Specifies a defeature orientation:
• Automatic
• Component XY
• Component YZ
• Component XZ
• Global XY
• Global YZ
• Global XZ

Defeature
Orientation

Includes appearances and textures
in the defeatured model.

Propagate

Omits appearances and textures
from the defeatured model.

Don't
propagate

Visual properties

Displays the selected rule.
Click Selection Criteria to modify the rule.

Rule Definition
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Propagating Visual Properties in Defeature Groups

You can include appearances and textures in a defeatured group.

To propagate visual properties in defeature groups:

1. Open a model, and click Defeature (Tools toolbar) or Tools > Defeature.

2. In the PropertyManager, select Silhouette .

3. Click Next until the Defeature - Define Groups page appears.
4. Under Simplification Method, select Propagate visual properties.
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Repairing Missing References in Linear or Circular Component Patterns

You can repair missing direction references in linear component patterns and circular
component patterns.

For linear component patterns, SOLIDWORKS repairs the missing direction reference by
selecting a reference on the component that is the same type and orientation, and is
either the same location or the closest entity to the missing reference.

For circular component patterns, SOLIDWORKS repairs the missing direction reference
by selecting a reference on the component that is the same entity and is coaxial with the
missing axis. If there are multiple options for a replacement axis, SOLIDWORKS selects
the closest to the missing axis.

You cannot use Auto Repair in Large Design Review mode.

To repair missing references in linear or circular component patterns:

1. Open a model that contains a linear component pattern or a circular component
pattern with a missing direction reference.

2. Right-click the pattern and in the context toolbar, click Auto Repair .

If SOLIDWORKS cannot repair the error, you are prompted to repair the pattern
manually.
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Mate References

When creating mate references, you can select Create mates only when names match
to create mate references only when the mate reference names are the same. The name
match applies to primary, secondary, and tertiary reference entities.

To use Create mates only when names match, you must select this option on both
components in the mate reference.

When more than one mate reference is available, the Select Mate Reference dialog
box displays a list of mate references.

The dialog box can appear when using these workflows:

• Inserting a component.
• Dragging a component from the FeatureManager® design tree.
• Dragging a file from the File Explorer tab in the Task Pane.
• Dragging a file from the Design Library tab in the Task Pane.

In the Mate Reference PropertyManager, you can select Lock Rotation for Concentric
mates.

To create mates only when the names match:

1. Open a model with a mate reference where the name of the mate reference is different
for each component.

2. Open one of the components from the mate reference.
3. In the FeatureManager design tree for the component, under the Mate References

folder, right-click a mate reference and click Edit Definition.
4. In the Mate Reference PropertyManager, under Reference Name, select Create

mates only when names match.
5. Copy the Reference Name value to use later.
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6. Open the other component in the mate reference and repeat the steps to enable
Create mates only when names match.

7. For Reference Name, enter the name from the first component.
8. Close both components.
9. In a model, click Insert > Reference Geometry > Mate Reference.
10. Under References, select Create mates only when names match.
11. Select the two components to mate.

To select a mate reference in the Select Mate Reference dialog box:

1. Open a model where multiple references are available between two components.

In this example, you create a mate reference between a knob and a plate. The plate
has several positions that you can select.

2. Drop the knob over the plate.

Select Mate Reference appears when the knob is over the plate.

3. In the Select Mate Reference dialog box, select a reference.
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Auto-Repair for Missing Mate References

Improvements to Auto Repair for concentric and parallel mates add more criteria for
identifying replacement entities.

For concentric mates, SOLIDWORKS repairs the missing reference by selecting a face on
the same component that has a different diameter and the same axis position.

For parallel mates, SOLIDWORKS repairs the missing reference by selecting a reference
on the same component that has a different position. For planar faces, the missing
reference is repaired with a different planar face that has the same orientation. For plane
references, the missing reference is repaired with a different plane that has the same
orientation. If a matching plane is not available, SOLIDWORKS uses a planar face that
has the same orientation to repair the missing plane reference.

To auto-repair missing mate references:

1. Open a model that contains a concentric mate error.

2. Right-click the mate and in the context toolbar for the mate, click Auto Repair .

If SOLIDWORKS cannot repair the error, you are prompted to solve the mate
manually.
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Assigning Component References to Top-Level Components

In the Component References dialog box, you can enter component references for all
top-level components. You can use the tree order from the FeatureManager design tree
as the component reference.

To assign component references to top-level components:

1. Open a model.
2. Right-click the assembly name in the FeatureManager design tree and click Edit

Component References.
3. In the Component References dialog box, under Component Reference, enter a

component reference for each component.

To use the component order from the FeatureManager design tree, click Use Tree
Order. Existing component references are overwritten.
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Specifying a Prefix and Suffix for Components

You can use a system option to specify a default prefix and a default suffix for
opposite-hand versions of mirrored components. You can also specify a default prefix for
virtual components created from external files.

To specify a prefix andsuffix for components:

1. Click Tools > Options > System Options > Assemblies.
2. Under Prefix / Suffix defaults, specify options:

a. For Opposite hand mirror components, select Add Prefix or Add Suffix, and
enter text.

b. For Prefix for virtual components created from external files, enter text.

3. Click OK.
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10
Detailing and Drawings

This chapter includes the following topics:

• Keeping Chain Dimensions Collinear
• Overridden Dimensions
• Reattaching Dangling Dimensions
• Excluding Hidden Sketches from Flat Pattern DXF Files
• Highlighting Referenced Elements
• Keep Link to Property Dialog Box Open
• Opening a Drawing in Detailing Mode by Default
• Select Multiple Layers

Keeping Chain Dimensions Collinear

You can ensure that chain dimensions remain collinear even with limited space.

When dimension text and arrowheads overlap, you can select options for the best fit.

To keep chain dimensions collinear when dimension text overlaps:

1. Click Tools > Options > Document Properties > Dimensions > Linear > Chain
Dimension.
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2. Under Collinearity Options, select Offset text automatically when space is
limited.

For ISO and ANSI, this option is selected by default.

To keep chain dimensions collinear when arrowheads overlap:

1. Click Tools > Options > Document Properties > Dimensions > Linear > Chain
Dimension.

2. Under Collinearity Options, select When arrowhead overlaps substitute
arrowhead termination automatically with: and specify an option:

• Points. Replaces arrowheads with points.
• Oblique Strokes. Replaces arrowheads with oblique strokes.

For ISO, this option is selected by default.

Overridden Dimensions

You can choose to automatically change the color of overridden dimensions.

Previously, you had to click every dimension and view its properties to see overrides.

You can:

• Change the color of overridden dimensions automatically.

To specify the color, click Tools > Options > System Options > Colors. Under
Color scheme settings, edit the color for Drawings, Overridden dimensions.

To display the color, click Tools > Options > Document Properties > Dimensions
and select Highlight overridden dimensions in a different color.

• Restore the overridden dimension values to their original values.
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Right-click the overridden dimension and select Restore Original Value.

Reattaching Dangling Dimensions

You can reattach dangling dimensions in a way that makes the process more reliable.
You can reattach dimensions that are not dangling the same way.

The feature does not support:

• Imported dimensions
• DimXpert dimensions
• Chain dimensions
• Symmetric linear diameter dimensions
• Path length dimensions

To reattach dangling dimensions:

1. Right-click the dangling dimension and click Reattach.

SOLIDWORKS® highlights the dangling point with an X on the first extension line.

2. Select a point on the model to reattach the dangling point to the model.

The dangling point reattaches to the new selection.

SOLIDWORKS highlights the dangling point with an X on the next extension line.

3. Select a point on the model to reattach the dangling point to the model.

The dangling point reattaches to the new selection.
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Excluding Hidden Sketches from Flat Pattern DXF Files

In the DXF / DWG Output PropertyManager, when you export a sheet metal flat pattern
as a .dxf file, you can exclude hidden sketches.

To exclude hidden sketches from flat pattern DXF files:

1. In the PropertyManager:

a. Under Export, select Sheet metal.
b. Under Entities to Export, select Sketches and under Sketches, select Exclude

hidden sketches.
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Highlighting Referenced Elements

When you select a dimension, you can highlight the associated elements as well.

The feature does not support the following dimensions:

• DimXpert or sketch dimensions, such as angular running dimensions and ordinate
dimensions

• Cosmetic threads
• Feature dimensions
• Blocked highlight for silhouette edge endpoints
• Referenced edges or points blocked for break view and Detailing mode legacy
dimensions

To highlight referenced elements:

1. Click Tools > Options > Document Properties > Detailing.
2. Select Highlight associated elements on reference dimension selection.
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Keep Link to Property Dialog Box Open

When you create a note in a drawing, in the Link to Property dialog box, you can click
Add to keep the Link to Property dialog box open. You can enter more text or select
another property. The dialog box remains open until you click OK or exit the note.

Previously, you had to close the dialog box and reopen it. Now you can do everything at
once.

Opening a Drawing in Detailing Mode by Default
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You can open a drawing in Detailing mode by default.

You can use this to automatically open large drawings quickly.

To open a drawing in Detailing mode by default:

1. Click Tools > Options > System Options > Drawings > Performance.
2. Select Always open a drawing in detailing mode.

Select Multiple Layers

You can select multiple layers at once to modify.

Previously, you had to select one layer at a time to modify.

You can:

• Ctrl + select each layer that you want.
• Shift + select a range of layers.
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11
Import/Export

This chapter includes the following topics:

• Exporting to Extended Reality
• Canceling the Import of Third-Party CAD Files
• Importing STEP Assemblies as Multibody Parts

Exporting to Extended Reality

You can export SOLIDWORKS CAD files to .glb or .gltf file formats.

The files contain information such as geometry, appearances, textures, animations, motion
studies, configurations, display states, exploded views, lights, and metadata. For large
files, the export supports Draco, the standard file compression mechanism for .glb and
.gltf files.
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Canceling the Import of Third-Party CAD Files

You can cancel the import of a third-party CAD file with 3D Interconnect if importing takes
too long.

To cancel the import of third-party CAD files:

1. Click File > Open.
2. Optional: 3DEXPERIENCE® Users: If the Open from 3DEXPERIENCE dialog box appears,

click This PC.
3. In the Open dialog box, select a third-party CAD file and click Open.
4. In the Open Progress dialog box, while the import status is Reading model, click

Cancel or press Esc.

You cannot cancel when the import status changes to Loading model.

5. In the confirmation dialog box, click Yes.

Importing STEP Assemblies as Multibody Parts
Enhancements related to importing STEP, IGES, and IFC assemblies as multibody parts
include:

• Import is available with a SOLDWORKS® parts-only OEM version.
• The performance of importing STEP, IGES, and IFC assemblies as multibody parts is
improved up to 30%.
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12
SOLIDWORKS PDM

This chapter includes the following topics:

• Assembly Visualization
• Downloading Specific Versions of a File in Web2
• File Type Icons
• Check Out Option in Change State Command
• Copying Tree Dialog Box
• Viewing Check-Out Event Details
• System Variables
• Viewing License Usage
• Data Security Enhancements
• SOLIDWORKS PDM Performance Improvements

SOLIDWORKS® PDM is offered in two versions. SOLIDWORKS PDM Standard is included with
SOLIDWORKS Professional and SOLIDWORKS Premium, and is available as a separately
purchased license for non-SOLIDWORKS users. It offers standard data management capabilities
for a small number of users.

SOLIDWORKS PDM Professional is a full-featured data management solution for a small and
large number of users, and is available as a separately purchased license.
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Assembly Visualization

You can access SOLIDWORKS PDM variables in the SOLIDWORKS Assembly Visualization
tool.

The SOLIDWORKS PDM variables are listed under Properties in the Custom Column
dialog box of the Assembly Visualization tool. You can select variables, for example,
PDM-<Checked Out By> or PDM-Dateunder the SOLIDWORKS PDM section in
Properties and then view them in the Assembly Visualization panel.

To view SOLIDWORKS PDM custom variables in Assembly Visualization:

1. In the SOLIDWORKS PDM Administration tool, right-click SOLIDWORKS > Assembly
Visualization Propertiesand click New List.

2. In the Customize Assembly Visualization Properties - Visualization Properties List
dialog box, create a property list from the available variables.You can create multiple
lists of properties and view them in Assembly Visualization depending on the
permissions.
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Customize Assembly Visualization Properties Dialog Box

You can use this dialog box to specify variables for specific users or groups that they can
view in the SOLIDWORKS Assembly Visualization tool.

To open this dialog box:

1. In the Administration tool, expand SOLIDWORKS.
2. Right-click Assembly Visualization Properties and select New List.

Name
Specifies the name of the new properties list.

Variables

Displays the selected variable.Variable

Displays the name of the selected variable.Name

Adds the selected variable.Add

Deletes the selected variable.Delete

Moves the selected variables up or down.Up and down arrows

Selected Variable

Displays the list of available variables and lets you select a
variable from the list.

Variable

Displays the name of the selected variable and lets you update
the name.

Name

Users
Lists users and lets you specify users who can select the variables and view the list.

Groups
Lists groups and lets you specify groups whose members can select the variables and
view the list.
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Downloading Specific Versions of a File in Web2

SOLIDWORKS PDM Web2 lets you download a specific version of a file and its references.

You cannot select and download multiple files in a single operation.

The Download Version dialog box lets you select the version and settings for download.
To access this dialog box:

1. In the File list, select a file:

• Large screen layout. Click Download > Download Version.
• Small screen layout. Touch Download and then touch Download Version.

Download Version Dialog Box

You can use the Download Version dialog box to download a specific version of a file and
its references.

To open this dialog box:

• Select a file and click Download > Download Version.

Version
Select the version of the file to download.

Settings
The collapsible option that displays the download settings options for files.
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Downloads the file with its references.Download with
references

Downloads the latest version.Latest

Downloads the referenced versions.Referenced

Version

Preserves the paths of references relative to the parent file and
creates a folder structure as required.
When cleared, the folder hierarchy is flattened, and all
referenced files are uploaded to the same destination folder as
the parent file.

Preserve relative
paths

Downloads the drawing files associated with the file selected
to download.

Include drawing

Downloads the SOLIDWORKS Simulation results associated
with the selected files.

Include simulation

Files
Lists the file references to download. The file list includes customizable columns such as

State, Version, Size, and Path. Click ShowMore and specify the columns to display.

Total Files to Download
Displays the total number of files and the count of individual files to download.

Download
Downloads the selected files. When the download is complete, a message appears with
the number of downloaded files on the upper bar. If Web2 cannot download any references,
a warning message appears.

Download Version Dialog Box - Small Screen Layout

You can use the Download Version dialog box to download a specific version of a file and
its references.

To open this dialog box:

1. Select a file and touch Download.
2. Touch Download Version.

Displays the version list and where you can select a version to
download.

Filename and latest
version

Lets you specify options.Settings
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File Type Icons

You can view the file type icons for weldment cut list items and the files that were shared
using pasted shared overlays.

These icons are available in the dialog boxes for:

• File Details
• File Operations
• Web2

The type icons for cut list items are not available for SOLIDWORKS BOMs.
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Check Out Option in Change State Command

You can check out a file after the change state operation completes.

You can customize the column set of the Do Transition dialog box to include the Check
Out system variable. If you select Change State and Check Out for a file, the file is
checked out after its state changes.

Copying Tree Dialog Box
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In the SOLIDWORKS PDM File Explorer, the Copying Tree progress dialog box that appears
while copying a file tree (fromTools > Copy Tree) includes more detailed information.

The dialog box includes two progress bars:

• The first progress bar has the primary steps or actions of the overall copy tree operation,
such as Copying Files and Copying Variables.

• The second progress bar has:

• Secondary steps such as Preparing Files and Finishing add operation.
• File names with extensions.
• The number of files copied and the total number of files.

Viewing Check-Out Event Details

In SOLIDWORKS PDM File Explorer, you can view details of check-out and undo check-out
events in the History dialog box of a file.

Along with the other details, you can see which user has performed the operation.
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System Variables

System variables are more available and easier to access.

• The following system variables are available in the File List, Quick Search Result,
and Search Result column set types:

• <Latest Revision>
• <Local Revision>
• <Last Historic Workflow>
• <Last Historic State>

• The <Days in State> system variable is available as a default column in File list.
• In SOLIDWORKS PDM File Explorer, the user interface of the Version tab is improved
and has more system variables.

• The SOLIDWORKS PDM task pane add-in has more system variables.
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Viewing License Usage

You can view license details without any special administrative permissions.

In the Administration tool, the License node has the following subnodes:

• Server List. Lets you edit license servers.

The administrative permission Can update license keys is renamed as Can update
license server. You need this permission to edit license servers.

• License Usage. Lets you view license details. This helps you to ask users to log out
if they are not using the tool, request more licenses from the administrator, or decide
whether you need to switch to a different license type.
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Data Security Enhancements

In SOLIDWORKS PDM File Explorer and Web2, unauthorized users cannot view file
information in the Contains and Where Used tabs.

The warning message No rights to get latest or attached version displays.

SOLIDWORKS PDM Performance Improvements
SOLIDWORKS PDM 2024 has improved the performance of file-based operations.

The following operations are approximately two times faster:

• Add files
• Change state
• Copy tree

The copy tree to compressed archive operation is orders of magnitude faster.
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13
SOLIDWORKS Manage

This chapter includes the following topics:

• Measuring in a Document Preview
• Plenary Web Client CAD File Preview
• Field Conditions for Affected Items
• Task Automation
• Task Burn Down Chart
• Timesheet Working Hours
• Bill of Materials Quantity
• Process Output for Replacing BOM Items
• Adding Child Conditions to BOMs

SOLIDWORKS® Manage is an advanced data management system that extends the global file
management and application integrations enabled by SOLIDWORKS PDM Professional.

SOLIDWORKS Manage is the key element in providing Distributed Data Management.

Measuring in a Document Preview
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You can measure geometry in the Document Preview area.

You can use the measure tool when you preview a document supported by the eDrawings
Viewer.

To measure in a Document Preview:

1. In the main grid, select a part, assembly, or drawing record.

2. Click Document Preview .

The eDrawings® preview displays the selected SOLIDWORKS record.

3. Click Measure .
4. Select geometry to measure in the preview.

Plenary Web Client CAD File Preview

You can dynamically preview CAD files in the Plenary web client windows.

The preview is based on eDrawings and supports the same file type and functionality.

In previous releases, to get a dynamic preview you had to click a preview link to open
the SOLIDWORKS PDM Web 2 client.
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Field Conditions for Affected Items

You can add conditions for Affected Items mapped fields to control their existence and
default values.

When a field has a condition for its existence, that is, if the condition is required or not,
a blue asterisk appears in the column name. If you do not define a condition, the field is
always available, and a red asterisk appears.

Adding Required Fields to an Affected Item Field

To add required fields to an affected item field:

1. In the System Administration tool, open the Process Wizard.
To open the Process Wizard, right-click a process and click Administration.

2. If the process does not have at least one custom field, open the Item Fields wizard
and add a custom field.

You cannot define mapped fields as required fields.

3. Open the Workflow Properties wizard and select a stage in the workflow diagram.
4. Click Item Fields.
5. Select Required.

To add a condition, click ellipses in the first Condition column to open the Conditions
dialog box.

You can also add Item Fields to define the condition.

6. Click Save.
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Adding Default Values to an Affected Item Field

To add default values to an affected item field:

1. In the Administration Options tool, open the Process Wizard.
To open the Process Wizard, right-click a process and click Administration.

2. If the process does not have at least one custom field, open the Item Fields wizard
and add a custom field.

You cannot define mapped fields as required fields.

3. Open the Workflow Properties wizard and select a stage in the workflow diagram.
4. Click Item Fields.
5. Click the Default column and select a value from the list or enter a value.

Mapped fields cannot have a default value.

6. In the When column, select Start or Finish to specify when to enter the default
value to the field.
To add a condition, click ellipses in the second Condition column to open the
Conditions dialog box.

You can also add Item Fields to define the condition.

Task Automation

Task automation streamlines the preconfiguration process of handling tasks.

You can add conditions to control the creation of individual tasks. This helps to create
tasks that are based on process field values. For example, if multiple departments can
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participate in a process, each with their own task, you can add conditions to create the
tasks for the required departments.

Adding Task Conditions

You can add conditions to control the creation of individual tasks.

To add task conditions:

1. Open the Process Wizard for an existing process and navigate to the Workflow
Properties wizard.

2. Select a stage and click Tasks.
3. Click a task and select Enable conditions for selected Task.
4. Specify the task conditions.

Defining Task Completion Requirements

You can define individual tasks to complete before processes can move forward.

In previous releases, the only options to move a process forward was to complete all
tasks.

To define task completion requirements:

1. Open the Process wizard for an existing process and navigate to the Workflow
Properties wizard.

2. Select a stage and click Tasks.
3. Select a task.
4. Clear All tasks must be completed before this stage is completed.
5. In the task list, select the check box in the Complete column for each task to

complete.
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Task Burn Down Chart

The task burn down chart shows the progression of all project tasks.

The chart shows the number of tasks at the start of the project and the number of
remaining tasks at the end of the selected period. You can see only uncompleted tasks
using the option, Show uncompleted tasks only.

The burn down chart does not show canceled tasks.

To open the burn down chart, in the Home module, click Tasks.
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Timesheet Working Hours

The Working Hours in a timesheet lets employees enter their daily working time for a
week.

This helps employers track the working hours and breaks of employees.

Configuring Timesheet Working Hours

To configure timesheet working hours:

1. In the System Administration tool, clickStructures > Timesheets.
2. Under Working Hours, select Enabled.

Working Hours appears in all new and existing timesheets.
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3. Specify Working Hours options:

DescriptionOption

Lets you specify working hours options.Enabled

Allows total hours for a day other than
zero.

If you select Show Type row and if
the value for Exclusions matches the
type you enter, you can enter total
hours as 0.

Working hours are required

Lets you enter values corresponding to
the Type.Exclusions

Creates workweek templates to reduce
the number of entries in a template.

Configure Templates

Lets you add comments for each day and
time slot.

Configure Comments

Displays a Type row for you to select a
type from the list.

Show Type row

Specifies the required Type options.Configure Types

Specifies the days in the workweek.Working Days

Configuring Templates

You can create and configure workweek templates to reduce the number of entries in a
template.

To configure templates:

1. Click Configure Templates.
2. In the Templates dialog box, click New.
3. In the Template Properties dialog box, enter a name for the template.
4. Optional: Select Default to specify this template as the default whenever you create

a new timesheet.
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5. Enter time values in each day or click arrows to select values for the following:

FormatValueOption

24-hourWork start time for a dayStart

hh:mmBreak time during the dayPause duration

24-hourWork end time for a dayEnd

Calculated based on the
other values you specify

Total Time

Configuring Comments

You can add comments for each day and time slot.

Administrators can add comments by clicking Configure Comments and entering values
in a list format. You can modify a comment from the list or enter new text.

Bill of Materials Quantity

You can see the number of component BOMs on the Where Used tab.

On the Where Used tab, under BOM Source, you can see the number of BOMs displayed
in parenthesis. In previous releases, you had to open the parent record to search for
component BOMs.
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Adding Custom Columns to the Where Used Tab

You can define custom field columns on the Where Used tab. This displays the custom
field information with the standard system fields.

To add custom columns to the Where Used tab:

1. Log in to the SOLIDWORKS Manage desktop client as an administrator.
2. Open the property card for a record in the object to which you want to add a custom

column.
3. Select the Where Used tab.
4. Select the BOM tab.

5. Click (Where Used toolbar).
6. In the Custom Fields dialog box, click New.
7. In the Field Properties dialog box, enter a Display Name.
8. Click Type and select a data type.
9. Click a cell in the Field column of the required object and select a field to display.
10. Repeat the previous step for required objects to get field values from.
11. Click Save and Close.
12. Add additional custom fields as required.

Process Output for Replacing BOM Items

In BOMs, you can replace a record with another record.

You can replace a line item used in many assemblies without editing each assembly. The
output is called Replace BOM items. To use Replace BOM items, you need two object
type fields: one object type field holds a source item and other holds a target item.

Mass replace works only for record objects and not for SOLIDWORKS CAD references.
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Enabling Mass Replace in a Process

To enable mass replace in a process:

1. In the System Administration tool, under Structures > Processes, edit an existing
Process object.

2. In the Process Wizard, open the Fields page.
3. Click New Field to create a new object type field.
4. Enter a display name and select Object Type as the field type.
5. Click Finish.
6. In the Object Type Field Properties dialog box, click Next.

Do not select Allow Multiple Items. You can replace a single record only.

7. Click Next again.
8. On the Select Object(s) page, select the objects where the items to replace come

from.
9. Click Next.
10. On the Select Columns page, specify options.
11. Click Next.
12. On the Choose User Rights page, specify access permissions for the field.
13. Click Finish.
14. Repeat steps 3 to 13 to add an object type field to hold the target item.
15. In the Process Wizard, open the Workflow Properties wizard.
16. Select the stage where you want to replace the record.

17. Click Outputs and click Add .
18. In the Outputs dialog box, in Select Type, select Replace BOM items and click

Save.
19. In the Replace BOM items dialog box, under Step 1, select the object type field for

the source item in Item to replace and the target object type field in Item to
replace with.

20. Under Step 2, specify the behavior for the target parent objects to update.

Select the parent objects to add as affected items in the process.

21. Click Save and Close.

Replacing BOM Items

To replace BOM items:

1. In SOLIDWORKS Manage, navigate to the process object of the Replace BOM items
output.

2. Click New (Main toolbar).
3. Select the item to replace and the item to replace with in the object type fields.

4. On the Affected Items tab, click BOM replacements analysis .
5. In the Replacement Analysis dialog box, select the required parent records to have

the items replaced.
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6. Click Add to list to close the dialog box and add the selected records to the affected
item list.

7. Move the process through its workflow past the stage where you added the Replace
BOM items output.
To see the updated BOMs, open the record for an affected item.

Adding Child Conditions to BOMs

You can add conditions to restrict the addition of child item records based on the record’s
status and field values. This helps apply company policies for adding records to BOMs.

To add child conditions to BOMs:

1. In the System Administration tool, under Structures, select an object and click Edit
.

2. Open the Bill of Materials wizard.

If you edit a record or document object other than a SOLIDWORKS PDM object, click
the BOM tab.

3. Select the Bill of Material object in the list and click Edit .
4. In the BOM Properties dialog box, click the Children tab.
5. Click the cell under Statuses allowed for the BOM variant and select the required

status.
6. In the Conditions column for a BOM object, click ellipses in the cell to add conditions

that restrict items to add to the BOM.
7. In the Do not allow adding items to BOM if these conditions are met dialog box, enter

the required conditions and warning message.
8. Click Save and Close.
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14
SOLIDWORKS Simulation

This chapter includes the following topics:

• Automatic Saving of a Model File
• Bonding Interactions for Shells
• Convergence Check Plot
• Decoupling Mixed Free Body Modes
• Direct Sparse Solver Retired
• Enhanced Bearing Connectors
• Excluding Mesh and Results When Copying a Study
• Exporting Mode Shape Data
• Mesh Performance
• Performance Enhancements
• Underconstrained Bodies Detection

SOLIDWORKS® Simulation Standard, SOLIDWORKS Simulation Professional, and SOLIDWORKS
Simulation Premium are separately purchased products that you can use with SOLIDWORKS
Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

Automatic Saving of a Model File
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You can save a model file after meshing and after the analysis completes.

To turn on automatic saving of a model file:

From the System Options > General tab, select Save file after meshing and after
the analysis completes.

Saving a model file automatically after meshing and after the completion of analysis
prevents data loss in case of unexpected system crashes or power outages.

Bonding Interactions for Shells

The enforcement of bonding interactions between sets of shell elements that have a
physical gap is more robust.

The image above shows a model with three shell surfaces. One pair of shells has a physical
gap of 1mm, while the second pair of shells has a gap of 1.1mm. By setting a user-defined
Maximum gap for bonding to 1mm (the maximum gap between geometric entities to
enforce local bonding interactions), only the pair of shells with a gap of 1mm should be
bonded.

An improved algorithm enforces the proper bonding interactions irrespective of the mesh
size. In previous releases, if you applied a coarse shell mesh to the three surfaces, the
algorithm erroneously enforced a bonding interaction to the second shell pair with a
1.1mm gap.
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Convergence Check Plot

The Convergence Check Plot detects regions of the model where the solver has
encountered contact convergence issues.

To access the Convergence Check Plot:

Do one of the following:

• Click Diagnostic Tools > Convergence Check Plot (Simulation CommandManager).
• In a simulation study tree, right-click Results and click Convergence Check Plot.

92

SOLIDWORKS Simulation



Decoupling Mixed Free Body Modes

An algorithm can detect and decouple the mixed free body modes while calculating mode
shapes.

From the Study Properties dialog box, select Decouple the mixed free body modes.
In cases where mixed free body modes exist in a model, the algorithm resolves the mixed
motion associated with a rigid body mode and provides the precise mode shape of a rigid
body mode.

The option to decouple the mixed free body modes is available in Frequency, Linear
Dynamic, Harmonic, Random Vibration, and Response Spectrum Analysis studies.
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Direct Sparse Solver Retired

The Direct Sparse solver is removed from the list of solvers for simulation studies.

For legacy studies that use the Direct Sparse solver, SOLIDWORKS Simulation uses the
Intel® Direct Sparse solver.

Enhanced Bearing Connectors
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The introduction of Distributed coupling and Tilt stiffness enhances the formulation of
bearing connectors.

The bearing connector is enhanced as follows:

• A Distributed type is added to the connector's Connection Type options. For a new
bearing connector definition, the default Connection Type is Distributed.

• The addition of Tilt stiffness accounts for the bending stiffness of the shaft.

To simulate the Allow Self-alignment option, which was available in prior releases,
set the Tilt stiffness to zero.

• You can apply a user-defined torsional stiffness to stabilize the shaft rotation.

The bearing connector enhancements are available for Linear static, Frequency, Buckling,
and Linear dynamic studies.

Excluding Mesh and Results When Copying a Study

You can save time by excluding mesh and results data when copying a simulation study
to a new study.

You can specify global default settings to include or exclude mesh and results when
copying a study from the Default Options > Solver and Results > Copy study dialog
box.

For individual studies, you can modify the default settings for Include mesh and Include
results in the Copy Study PropertyManager.
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Exporting Mode Shape Data

You can export mode shape data to the study's study_name.out file.

From the Frequency > Options dialog box, select Export mode shape data.

The mode shape data are saved to the study's .out file, located in the Results folder.

96

SOLIDWORKS Simulation



Mesh Performance

The meshing time with the Blended curvature-based mesher is reduced for assemblies
that have multiple identical parts.

This mesh enhancement is available with the SOLIDWORKS Simulation Premium and
SOLIDWORKS Simulation Professional licenses.

An improved mesh algorithm based on the Blended curvature-based mesher identifies
identical parts that are repeated in an assembly. The algorithm reuses the same mesh
for the identical parts instead of meshing each of them independently, thus saving meshing
time.

To use the improved mesh algorithm, from the Default Options > Mesh dialog box,
select Reuse mesh for identical parts in an assembly (Blended curvature-based
mesher only).
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Performance Enhancements

Several feature enhancements improve the performance and accuracy of simulation
studies.

• Results from studies with remote displacements or remote rotations that are applied
to large faces with the Distributed connection are more accurate.

The solution time for these studies is shorter with the Intel Direct Sparse solver. In
previous releases, when the number of coupling nodes was very large, only a subset
of the coupling nodes participated in the distributed coupling constraints. In
SOLIDWORKS Simulation 2024, the distributed coupling constraints for remote
displacements or remote rotations include all coupling nodes.

The image illustrates the performance gain of the Intel Direct Sparse solver for a model
that has a remote displacement applied with distributed coupling to approximately
29,600 coupling nodes.

The solution time with the FFEPlus iterative solver for similar studies is not faster in
SOLIDWORKS Simulation 2024. However, the stress results are more accurate
because all coupling nodes are considered in the distributed coupling formulation.

• Running larger linear dynamic studies is more efficient. The stress calculation of larger
linear dynamic studies is optimized because of improved memory allocation by the
solver.

• Improved memory estimate, allocation, and management by the solver allows the
completion of large surface-to-surface bonded interaction sets that previously failed
because of insufficient memory. This improvement applies to the SOLIDWORKS
Simulation Professional and SOLIDWORKS Simulation Premium licenses.
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Underconstrained Bodies Detection

There are several usability enhancements for the Underconstrained Bodies
PropertyManager.

• You can copy the results of the underconstrained bodies detection tool to the clipboard.
• The list that shows the bodies that are not sufficiently constrained in the Results
section is expandable for improved readability.

• It takes less time to show the animations of underconstrained bodies. The graphics
quality of the animations that highlight underconstrained bodies is improved.
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15
SOLIDWORKS Visualize

SOLIDWORKS® Visualize is a separately purchased product that you can use with SOLIDWORKS
Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium, or as a completely separate
application.

Enhanced Capabilities for Creating Compelling Appearances

SOLIDWORKS Visualize uses Dassault Systèmes' Enterprise PBR Shading Model (DSPBR)
to closely replicate the realistic appearance of metal, glass, plastic, and other surfaces.

DSPBR is a material model for physically based rendering, supported by all renderers in
the 3DEXPERIENCE® platform. The shading model is easy to use and renderer independent.
It combines metallic and dielectric scattering distribution functions, including transparency
for thin-walled and volumetric objects. It also provides effects, such as emission, clear
coat, metallic flakes, and sheen, to cover a range of appearances.

SOLIDWORKS Visualize provides appearances for an expanded range of material types
and subtypes. The full Enterprise PBR Shading Model consists of more than 30 parameters,
which may be overwhelming. To address this, the software introduces subtypes that
expose a subset of the parameters relevant to specific material types. The subtypes
simplify the user interface and enhance usability while keeping unnecessary parameters
hidden.
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Enhancements include:

• A simplified interface for selecting appearance types and optimizing their parameters.
You can select appearance types from a list or by clicking thumbnail images.

• The ability to adjust textures and texture maps for almost all parameters, with greater
control and fidelity.

• The ability to combine normal and displacement maps and to apply vector displacement.

Aside from the Enterprise PBR Shading Model, appearance subtypes include Basic, Metal,
Glass, Plastic, Leather, Textile, Car Paint, Emissive, and Wood.

You do not need to convert existing files to the DSPBR appearances. You can continue
working with files created with legacy appearance types or convert them to the DSPBR
types. New files must use the DSPBR appearance types.

Sample projects and other assets are updated and improved for the DSPBR appearances.
Additional appearances and assets are available in the Cloud content library.

Parameters for Basic Subtype

The Basic subtype includes the most commonly used parameters for applying textures
and effects to surfaces.

Most parameters let you apply a texture and an effect on a surface as follows:

• To apply a texture, click .
• To apply an effect, enter a decimal value, or adjust the slider or spinner.

If you are new to applying appearances, start with the Basic subtype. Descriptions for
all the DSPBR appearances are available in the SOLIDWORKS Visualize help.

ValueDescriptionParameter

RGB
color

Specifies the overall RGB color of a material. You can
use it to apply color to thin walled transparent materials.

Albedo

Decimal.
[0..1]

Determines the level of metallicness of a surface.Metallic

Decimal.
[0..1]

Controls the level of shininess or roughness of a surface.Roughness

TextureAdds the appearance of details such as bumps and dents
to the surface of a model without changing the size of
the geometry.

Normal

TextureModifies the position of surface points using a texture
that specifies the length and direction of displacement
for each point.

Displacement

Decimal.
[0..1]

Adds a texture of holes to a surface without adding extra
polygons to the geometry.

Cut-Out Opacity
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16
SOLIDWORKS CAM

This chapter includes the following topics:

• Additional Probe Cycle Parameters
• Canned Cycle Threading for Reverse Cuts
• Correct Feed/Speed Data for Parts Comprising Assemblies
• Heidenhain Probe Type
• End Conditions for Islands in the 2.5 Axis Feature Wizard
• Leadin and Leadout Parameters for Linked Contour Mill Operations
• Minimum Hole Diameter for Thread Mill Operations
• Post Processor Path
• Probe Cycles
• Probe Tool Output Options
• Probing Cycles in Assembly Mode
• Setup Sheets
• Shank Types for Mill Tools
• Tool Select Filter Dialog Box
• Tool Selection - Flute Length
• Tool Selection - Tool Crib Priority

SOLIDWORKS® CAM is offered in two versions. SOLIDWORKS CAM Standard is included with
any SOLIDWORKS license that has SOLIDWORKS Subscription Service.

SOLIDWORKS CAM Professional is available as a separately purchased product that you can
use with SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.
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Additional Probe Cycle Parameters

The Additional Probe Cycle Parameters dialog box contains options for Stop if tolerance
exceeded and Print (Ww) / Measuring Log.

Stop If Tolerance Exceeded

If a probe cycle goes beyond tolerance limits, the Stop if tolerance exceeded parameter
specifies whether to interrupt the program and display the details of the violation.

Values you can specify for this parameter:

• 0. Does not interrupt the machining program or display the violation details if tolerance
limits are violated.

• 1. Interrupts the machining program and displays the violation details on the controller.

The command associated with this parameter in the posted code is

Q309=1 ;PGM STOP TOLERANCE

Print (Ww) / Measuring Log

The Print (Ww) parameter is renamed to Print (Ww) / Measuring Log.

The functionality for Print (Ww) / Measuring Log depends on the Probe Type selected.

Print (Ww) / Measuring Log FunctionalityProbe Type

Indicates whether the data is output in the post-processed code.Renishaw

Indicates whether to create, save, or display the measuring log.Heidenhain

Values you can specify for this parameter:
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• 0. Does not create the measuring log.
• 1. Creates the measuring log and saves it to the controller.
• 2. Interrupts the NC program and displays the measuring log.

Canned Cycle Threading for Reverse Cuts
For threading operations, SOLIDWORKS CAM supports the Canned cycle output option
for reverse cut types.

In the Operation Parameters dialog box, on the Thread tab, under:

• Cut type, select Reverse.
• Program point, select Canned cycle output.

Correct Feed/Speed Data for Parts Comprising Assemblies

In Assembly mode, if the different parts or the multiple instances of a part comprising
an assembly have different stock materials, then for each part or instance, the correct
stock material appears.

The associated stock material appears in the Operation Parameters dialog box on the F/S
tab for Stock material. The Feed/Speed Editor uses the Stock material for feed/speed
calculation.

In previous releases, in Mill Assembly mode, when an assembly contained parts that had
different stock materials or split part instances had different stock materials, the
feed/speed computations were often inaccurate. This occurred because SOLIDWORKS
CAM only considered the stock material assigned to the first part listed in the Part Manager
for feed/speed computation. SOLIDWORKS CAM assigned the calculated the feed/speed
values to the other parts that constituted the assembly though they had different stock
materials. This resulted in erroneous feed/speed values.
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Heidenhain Probe Type

SOLIDWORKS CAM supports probing operations on machine tools that use Heidenhain
controllers.

In the Machine dialog box, on the Posting tab, under Probe Options, in Probe Type,
select Heidenhain.

End Conditions for Islands in the 2.5 Axis Feature Wizard
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You can define the height of islands for 2.5 Axis features in two directions.

In previous releases, SOLIDWORKS CAM automatically specified island height from the
topmost point of the island face to the bottom of the feature. If the island face was a
different height than the top face of the feature, the resultant island was shorter compared
to the feature height. You could not increase the island height in the other direction to
match the feature height.

In the 2.5 Axis Feature: Island Entities PropertyManager, you can specify island height
under End condition - Direction 2. You can define the height in Z+ and Z- directions.
The direction associated with End Condition - Direction 2 is opposite to the bottom
profile of the island feature.

Leadin and Leadout Parameters for Linked Contour Mill Operations

For linked Contour Mill operations, you can specify an option to copy the Leadin and
Leadout parameters of the first Contour Mill operation to the other linked operations.

In the Operation Parameters dialog box, on the Leadin tab, select Apply leadin/out to
All. SOLIDWORKS CAM does not link these operation parameters because they are
feature-specific:

• Leadin/out point
• All parameters under Links between
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Minimum Hole Diameter for Thread Mill Operations

You can specify the minimum hole diameter for thread mill operations. In previous releases,
this parameter was read-only.

In the Technology Database (TechDB), on the Mill Tooling tab, select a Threading Tool
and specify Min. hole dia.

You can also specify Minimum hole dia in the Operation Parameters dialog box, on the
Tool tab, on the Thread Mill Tool secondary tab, under Tool Dimensions. Changes in
the Operation Parameters dialog box are not saved to the TechDB.
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Post Processor Path

You can specify the default location of the folder containing post processors on the Settings
tab of the Technology Database (TechDB). Under General, specify Post Processor Path.
You do not need to reselect the post processor for every part or assembly.

When you change the location of the folder containing post processors and you open a
previously programmed part or assembly in SOLIDWORKS CAM, the following occurs:

1. SOLIDWORKS CAM determines whether the post processor file is available in the
folder for Active post processor.

If the folder is unavailable, the software loads the Post Processor Path.

2. SOLIDWORKS CAM searches for the post processor file in Post Processor Path.
3. When SOLIDWORKS CAM finds the post processor file, it displays the file path of the

post processor file in the Machine dialog box on the Post Processor tab for Active
post processor.
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Probe Cycles
SOLIDWORKS CAM includes additional probing cycles to calibrate and measure planes
and axes.

Probing cycles include:

• 3 Point Plane
• Angle Measurement (X Axis)
• Angle Measurement (Y Axis)
• 4th Axis Measurement (X Axis)
• 4th Axis Measurement (Y Axis)

You can access probe cycles in the Operation Parameters dialog box on the Probe tab,
under Probe Cycle.

Three Point Plane

With the 3 Point Plane probe cycle, SOLIDWORKS CAM measures the selected surface
using three points on that surface. The probed points establish a plane.

When you select 3 Point Plane, SOLIDWORKS CAM positions the three points at default
offset values. You can modify the offset values and probe the points at the required
locations.
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Angle Measurement (X/Y Axis)

The Angle Measurement (X Axis) and Angle Measurement (Y Axis) probe cycles
probe two points on a selected surface and calculate the angle of the face with respect
to the X or Y axis, respectively.

SOLIDWORKS CAM positions the two points symmetrically around the centroid of the
selected face. In the Operation Parameters dialog box, on the Probe tab, under Probe
Cycle, you can specify the distance between the points in Incremental Distance for X
location and Y location.

The normal of the selected planar face must be perpendicular to the Z axis of the setup
where you insert the probe.
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4th Axis Measurement (X/Y Axis)

This probe cycle measures the slope of a selected surface between two points with respect
to the fourth axis.

The selected surface must be such that the slope between the probed points is measured
in the X or Y axis. You can use the resultant value to compensate the rotary axis.

The X and Y coordinates of the centroid of the surface are the start point of the toolpath.
SOLIDWORKS CAM positions the probing points symmetrically about this start point based
on the assigned distance between the two probing points.

The probe movements are parallel to the axis. SOLIDWORKS CAM measures the clearance
distance from the reference point on the surface. For the probing moves, the clearance
distance can be more or less than the defined.
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Probe Tool Output Options

You can specify the Output through parameter for probe tools. This parameter generates
the toolpath and G-code with the set tool reference point.

In the Operation Parameters dialog box, on the Tool tab, on the Probe Tool tab, under
Properties, you can specify options for Output through:

• Tip. Generates the toolpath with reference to the tip of the probe tool.
• Center. Generates the toolpath with reference to the center of the probe tool.
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Probing Cycles in Assembly Mode

You can assign appropriate part instance and mill part setups for each probe operation
generated in Assembly mode. This ensures an accurate Part Setup Origin while posting
the toolpath of the probe operation.

In previous releases, if only probe operations existed under an operation setup of an
assembly, SOLIDWORKS CAM measured their coordinates from the fixture coordinate
system (FCS). SOLIDWORKS CAM did not list the instance and relevant feature setup on
the Offset tab in the Setup Parameters dialog box. Even if you specified the output origin
as Part Setup Origin, the toolpath coordinates referred to the FCS, leading to inaccurate
posted code.

In the Operation Parameters dialog box, on the Posting tab, under Part/Setup, you can
specify parameters in Assembly mode.

DescriptionParameter

Enables the Reference part and Reference setup parameters.Assign reference
part and setup

Lists all parts in the Part Manager.
The default selection is the part (with the part instance as a suffix
if there are multiple part instances) whose face you selected in the
Probe tab for the Probe operation. If you did not select a face,
SOLIDWORKS CAM uses the first part listed in the Part Manager.

If the post processing requires you to specify the Part Setup
Origin, SOLIDWORKS CAM uses the values of the origin of the
selected part as reference. SOLIDWORKS CAM also uses the Part
Setup Origin to calculate the coordinates when executing Step
Through Toolpath and simulation commands.

Reference part

113

SOLIDWORKS CAM



DescriptionParameter

Lists all the part setups associated with the part or part instance
selected in Reference Part.

The default selection is the valid feature setup for the part or part
instance selected for Reference Part whose features can be
machined from the selected operation setup.

SOLIDWORKS CAM uses the origin of the part setup that you select
to compute the coordinates of the toolpath while posting.

Reference setup

For Probe operations, the selections you make for Reference part and Reference setup
are displayed in the part instances and work coordinates on the Offset tab of the Setup
Parameters dialog box.
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Setup Sheets

The default format for Setup Sheets is .xslt for compatibility with the latest browsers.

Shank Types for Mill Tools

You can define shank types (Straight, Tapered, or Neck) for any Mill Tool.

In previous releases, only certain Mill Tools could have shank types. You can specify shank
types for the noncutting portion of these additional tools:
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• Bore Tool
• Center Drill
• Countersink Tool
• Dovetail Tool
• Keyway Tool
• Lollipop Tool

Neck. You can define the
shoulder diameter, shoulder
length, shank diameter, and
shank length. The neck
portion of the tool is the
noncutting portion of the
cutting tool.

Tapered. You can define the
shoulder diameter, shoulder
length, shank diameter, and
shank length. The tapered
portion of the tool is the
noncutting portion of the
cutting tool.

Straight. You can define the
shoulder length and shank
diameter.

• D2 = Shank diameter
• D4 = Shoulder diameter
• L4 = Shoulder length
• L6 = Shank length
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Tool Select Filter Dialog Box

You can resize the Tool Select Filter dialog box to see additional table columns.

Tool Selection - Flute Length

When you specify tool selection criteria based on Use Expression and not on a specific
tool, SOLIDWORKS CAM accounts for the tool's flute length.

When you run Generate Operation Plan, for each operation that you define the tool
selection criteria with a Tool diameter lower/upper expression, the following rules apply:
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• If the tool crib has two or more tools with identical diameter values matching the
expression criteria, SOLIDWORKS CAM accounts for the flute length to assign the tool.
It selects the tool with a flute length more than the feature depth. If all tools have a
flute length more than the feature depth, SOLIDWORKS CAM selects the tool with a
flute length closest to the feature depth.

• If SOLIDWORKS CAM still finds two or more tools, it uses the rules of Stock/Tool
Material Mapping to select a tool.

For example, consider a rectangular pocket with a feature depth of 75mm. Based on the
feature strategy assigned to this feature, the tool selection criteria selects a 25mm Flat
End Mill. The tool crib has two Flat End Mill tools with identical diameters of 25mm.
However, one tool has a 50mm flute length and the other has an 80mm flute length.
SOLIDWORKS CAM selects the tool with the 80mm flute length because it is closer in
value to the feature depth.

Tool Selection - Tool Crib Priority

SOLIDWORKS CAM has better tool selection logic when you select Tool crib priority in
the Technology Database (TechDB).

SOLIDWORKS CAM has optimized tool selection logic so appropriate tools are available
in the active tool crib:

• If the tool assigned in the TechDB for a specific operation is not in the active tool crib,
SOLIDWORKS CAM adds it to the tool crib even though smaller tools might be in the
active tool crib. (If you selected a tool by referencing it to a specific Machine ID in
the TechDB.) If another tool with similar parameters is in the active tool crib,
SOLIDWORKS CAM uses that tool.

• If you specify that the resultant tool derived from the expressions defined in the TechDB
as inactive, SOLIDWORKS CAM does not add it to the active tool crib. It uses the
subsequent tool selection rules to add an active tool to the tool crib.
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17
SOLIDWORKS Composer

This chapter includes the following topics:

• Offline Help for SOLIDWORKS Composer Products
• Support for SpeedPak Configurations in SOLIDWORKS Composer

SOLIDWORKS® Composer™ software streamlines the creation of 2D and 3D graphical contents
for product communication and technical illustrations.

Offline Help for SOLIDWORKS Composer Products
Offline Help for all SOLIDWORKS Composer products is available as a PDF instead of in
HTML format.

In earlier releases, offline Help worked only in Microsoft Internet Explorer. Now it is
browser independent.

Support for SpeedPak Configurations in SOLIDWORKS Composer
You can translate SOLIDWORKS assembly files containing components in SpeedPak
configurations to SOLIDWORKS Composer.

The SpeedPak components are switched to their parent configurations to enable translation
of these components to SOLIDWORKS Composer.
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18
SOLIDWORKS Electrical

This chapter includes the following topics:

• Aligning Components
• Changing the Length of Multiple Rails and Ducts
• Filtering Auxiliary and Accessory Parts
• Auto Balloons in 2D Cabinets
• Removing Manufacturer Part Data
• Resetting an Undefined Macro Variable
• Shortening Lists Using Ranges
• SOLIDWORKS Electrical Schematic Enhancements
• SOLIDWORKS Electrical Performance Improvement

SOLIDWORKS® Electrical is a separately purchased product.

Aligning Components
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When you use Align Components while designing 3D cabinet layouts, you can preview
changes in the graphics area.

This significantly reduces the effort required to align SOLIDWORKS components in 3D
cabinet layouts.

The Align Component PropertyManager has a simplified and improved workflow.

Changing the Length of Multiple Rails and Ducts

You can change the length of multiple rails and ducts simultaneously. In earlier releases,
you could only change the length of a single rail or duct. The multiselection of rails and
ducts makes the process of 3D cabinet creation faster.

To change the length of multiple rails and ducts:

1. In the SOLIDWORKS Electrical 3D menu, click Change Length of Rails and Ducts

.
2. In the PropertyManager, under Define Length > Select Components, select

multiple rails and ducts in the graphics area.
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Filtering Auxiliary and Accessory Parts

In SOLIDWORKS Electrical, you can filter manufacturer parts based on your selection.
You can filter:

• Associated manufacturer parts
• Accessory manufacturer parts
• Auxiliary manufacturer parts
• Manufacturer parts excluded from the BOM

You can use the list in Filter Manufacturer Parts in the Electrical Manager tree to
filter various types of manufacturer parts. Show/Hide Associated Components is
replaced by this filter option.

This feature is also available in the 2D cabinet layout of SOLIDWORKS Electrical
Schematic.
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Auto Balloons in 2D Cabinets

You can insert auto balloons in SOLIDWORKS Electrical 2D cabinet layout drawings.

Inserting Auto Balloons in 2D Cabinets

To insert auto balloons in 2D cabinets:

1. Click Cabinet Layout > Auto Balloon .
2. Select a drawing view in which to insert the balloons.

3. In the PropertyManager, specify options and click .

Auto Balloon PropertyManager

To open this PropertyManager:

1. Click Cabinet Layout > Auto Balloon .

Leader styles

Specifies the predefined style to apply to leaders.Leader style

Specifies the block to use for the balloons.Block

Specifies a number for the scale to apply to the block used
for balloons.

Scale
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Balloon layout
Specifies the Pattern type.

Displays balloons on the top of the cabinet drawing.Top

Displays balloons on the bottom of the cabinet drawing.Bottom

Displays balloons on the left of the cabinet drawing.Left

Displays balloons on the right of the cabinet drawing.Right

Displays balloons in a square surrounding the cabinet
drawing.

Square

Displays the arrows of the grouped balloons with less tilt.Group balloons

Inserts balloons only for the first instance of the same
manufacturer part.

Ignore multiple
instances

Does not insert balloons for the terminal strip.Ignore terminals

Layer
Specifies the layer on which to insert the balloons.

Options
Insert report table. Inserts a report table filtered from the content of the current
document.

• If the document contains a report table, select Update report table to update the
report table.

• The number of balloons associated with parts in the report appears in a separate
report template.
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Removing Manufacturer Part Data

You can clear manufacturer part information when deleting or replacing a part from a
component.

To remove manufacturer part data, click Electrical Project > Configurations > Project.
In the Electrical Project Configuration dialog box, in the General tab, under Options,
select Reset manufacturer part information from component. This resets the related
information such as manufacturer data, terminal mark when you delete or replace it with
a different part.

The option is cleared by default. If you clear this option, the part retains the terminal
numbers even after you delete or replace it.
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Resetting an Undefined Macro Variable

Excel automation lets you automatically reset undefined macro variables.

To reset undefined macro variables, click SOLIDWORKS Electrical > Configurations
> Project. In the Electrical Project Configuration dialog box, on the General tab, under
Excel automation, select Reset undefined macro variable. When you select this
option, the %xxx% variable does not remain in the inserted macro. It is replaced by:

• An empty string
• A removed object
• Associated default object (like function or location)
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Shortening Lists Using Ranges

In report configuration, when you merge rows, the software lists consecutive values as
a range for merged rows instead of listing each individual value in the range.

In the Report configuration edition dialog box, under Columns, select Value range. To
activate this option, selectMerge rows. You can activate this option for multiple columns
at once.

SOLIDWORKS Electrical Schematic Enhancements
SOLIDWORKS Electrical Schematic offers an improved user experience.

• In drawings, you can move entities using the arrow keys.
• The grid point size for the project sheets adapts automatically to the screen resolution.
• In a schematic project, when you set the side panels to Auto Hide, the panels retain
the auto hide setting. This behavior increases the app's usability.

SOLIDWORKS Electrical Performance Improvement
Archiving a project for remote users (VPN connection) is improved and is much faster
now.
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19
SOLIDWORKS Inspection

SOLIDWORKS® Inspection is a separately purchased product that you can use with SOLIDWORKS
Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium, or as a completely separate
application (see SOLIDWORKS Inspection Standalone).

Welcome Page

The redesigned Welcome to SOLIDWORKS Inspection page in SOLIDWORKS Inspection
Standalone improves usability.

The welcome page includes:

• Recent Documents
• Recent Folders
• Recent Projects
• Resources
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20
SOLIDWORKS MBD

This chapter includes the following topics:

• Hole Tables
• Repairing Dangling Dimensions
• Adding a Decimal Separator in Geometric Tolerance Symbols
• Controlling Visibility of Annotations through Solid Geometry
• Displaying Dual Dimensions in Geometric Tolerance Symbols
• Creating Thickness Dimensions for Curved Surfaces
• Displaying Half Angles of Conical Dimensions
• Exporting Custom Properties to STEP 242
• Viewing Annotations and Dimensions

SOLIDWORKS® MBD is a separately purchased product that you can use with SOLIDWORKS
Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

Hole Tables
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You can include a hole table when you publish a part to 3D PDF.

Repairing Dangling Dimensions

You can repair dangling dimensions.

You can edit the dangling dimensions to reattach them to a feature in the model. This

applies to dimensions created using the DimXpert tools, such as Size Dimension ,

Location Dimension , and the Angle Dimension tool.

To repair dangling dimensions:

1. Open a part or assembly that contains dangling dimensions in DimXpert.
2. In the FeatureManager® design tree, right-click a feature and select Edit Feature.
3. In the Reference dialog box, select the missing reference to repair the dangling

dimension.

This tool is available for DimXpert dimensions.
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Adding a Decimal Separator in Geometric Tolerance Symbols

You can add a decimal separator in geometric tolerance symbols.

To add a decimal separator in geometric tolerance symbols:

1. Click Tools > Options > Document Properties > Annotations > Geometric
Tolerances.

2. Under Decimal Separator, specify an option:

• Comma. Inserts a comma.
• Period. Inserts a period.
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Controlling Visibility of Annotations through Solid Geometry

You can make annotations, such as dimensions, stay on top of the model. This lets you
see dimensions and extension lines if you rotate the model.

To control visibility of annotations through solid geometry:

1. Click Tools > Options > System Options > Display.
2. Select Display DimXpert dimensions on top of model.

Displaying Dual Dimensions in Geometric Tolerance Symbols
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When you create geometric tolerance symbols, you can display dual dimensions, which
show two sets of values, such as inches and millimeters, within a single dimension.

To display dual dimensions in geometric tolerance symbols:

1. In a part or drawing, click Geometric Tolerance (MBD Dimension toolbar).
2. In the graphics area, click to place the symbol.
3. Select Range in the Tolerance dialog box and the Geometric Tolerance

PropertyManager and select Display Dual Dimensions.

Creating Thickness Dimensions for Curved Surfaces

You can create thickness dimensions for curved surfaces.

This helps show the relationships between surfaces. You can apply thickness dimensions
to:

• Cylinders
• Bosses
• Simple holes

You can create thickness dimensions between two concentric DimXpert features for:

• An inside and outside diameter, where the inside diameter is a cylinder or a simple
hole, and the outside diameter is a cylinder or a boss.

• Two inside diameters of a cylinder or simple hole.
• Two outside diameters of a cylinder or boss. For example:
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To create thickness dimensions for curved surfaces:

1. Click Location Dimension (MBD Dimension toolbar).

Steps 2 and 3 require that you select two features. For thickness dimensions, the
two features must be cylindrical, concentric, and have different diameters.

2. Select the face of the origin feature.
3. Select the face of the tolerance feature.
4. Click to place the dimension.

5. Specify options in the PropertyManager and click .

Displaying Half Angles of Conical Dimensions
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You can display a conical angle dimension as a half angle. This lets you convert a full
angle of a cone to a half angle.

To display half angles of conical dimensions:

1. In the DimXpert Value PropertyManager, under Primary Value, select Show as half
angle.

Exporting Custom Properties to STEP 242

You can export custom properties from a part or assembly to the STEP 242 format.

To export custom properties to STEP 242:

1. Click Publish STEP 242 File (MBD toolbar).
2. In the Publish to STEP242 PropertyManager, specify custom properties to export and

click .
3. In the Save As dialog box, enter a file name.
4. Click Save.

Viewing Annotations and Dimensions
You can view annotations and dimensions in a more organized way.

As of SOLIDWORKS 2024 and later, you do not need a SOLIDWORKS MBD license for
this functionality.

You can use the following features:

• List annotations in a tree view. When you select an annotation in the FeatureManager
design tree, it highlights the annotation in the graphics area, and you can hide or show
annotations.
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• Sort by annotation type. You can sort annotations by type, such as smart dimensions,
weld symbols, and balloons for better organization.
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21
DraftSight

This chapter includes the following topics:

• Measure Geometry Command
• Selecting Multiple Files and Inserting as Reference
• Export Sheet Command
• Tool Palettes
• Make Flat Snapshot Command
• View Navigator
• Layer Manager Palette
• Merge Layer Command
• Reshaping Hatches

DraftSight® is a separately purchased product that you can use to create professional CAD
drawings. It is available as DraftSight Professional and DraftSight Premium. In addition,
DraftSight Enterprise and Enterprise Plus are available on network license. 3DEXPERIENCE®
DraftSight is a combined solution of DraftSight with the power of 3DEXPERIENCE platform.

Measure Geometry Command

137



You can use the MEASUREGEOM command to measure an area, angle, distance, and radius.

In previous releases, you had to run commands like AREA, DIST, and GETANGLE.

To access the Measure Geometry command:,

Do one of the following:

• On the ribbon, click Home > Tools > Measure Geometry.
• Enter MEASUREGEOM in the command window.

Selecting Multiple Files and Inserting as Reference

You can select multiple files and folders and insert them as external references to the
DWG™ file. This reduces the number of clicks required to insert multiple files and the
possibility of failing to insert a file.

To select multiple files and insert them as references:

Do one of the following:

• On the ribbon, click Insert > Block > References Manager.
• On the ribbon, click Attach.
• On the menu, click Tools > References Manager.
• Enter REFERENCES in the command window.
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Export Sheet Command

You can export all visible entities from an active sheet viewport and entities from the
sheets to the new drawing.

This lets you edit the representation created in the new drawing using commands like
TRIM, COPY/PASTE, EXPLODE, STRETCH.

To access the Export Sheet command:

Do one of the following:

• On the ribbon, click Sheet > Sheets > Export Sheet.
• On the menu, click File > Export > Export Sheet.
• Enter EXPORTSHEET in the command window.
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Tool Palettes

You can find frequently used tools and data in the Tool Palettes.

The palettes include all generic properties like docking and auto-hide. You can also create
your own palette to store tools and data.

To access the Tool Palettes:

Do one of the following:

• On the ribbon, click Insert > Palettes > Tool Palettes.
• On the menu, click Tools > Tool Palettes.
• Enter TOOLPALETTES in the command window.
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Make Flat Snapshot Command

You can use the enhanced features of the MAKEFLATSNAPSHOT command for formatting
the foreground and hidden lines, and displaying tangent edges.

To access the Make Flat Snapshot command:

Do one of the following:

• On the ribbon, click Home > Snapshot > Make Flat Snapshot.
• On the menu, click Solids > Solid Editing > Make Flat Snapshot.
• Enter MAKEFLATSNAPSHOT in the command window.

The enhanced features include:

• Foreground lines. LineColor and LineStyle specify the line color and style of
foreground lines.

• Hidden lines. Show displays the hidden lines. LineColor and LineStyle specify the
line color and style of hidden lines.

• Show tangent edges. Displays tangent edges in the flat representation.
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View Navigator

View Navigator lets you switch between standard and isometric views or parallel and
perspective views of a model.

Its interface acts as a 3D orientation indicator that lets you see the current view direction.

To access the View Navigator command:

• On the ribbon, click View > Views > View Navigator.
• On the menu, click View > View Navigator.
• Enter VIEWNAVIGATOR in the command window.
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Layer Manager Palette

You can use the Layer Manager dialog box as a palette that you can float or dock on the
side.

In the Layer Manager palette, you have quick access to layers, layer states, layer previews,
or isolating layers.

To open the Layer Manager palette:

• On the ribbon, click Home > Layer > Layers Manager.
• On the menu, click Format > Layer.
• Enter LAYER in the command window.
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Merge Layer Command

You can use the MERGELAYER command to reorganize layers.

This command is available from the Layer Manager palette that helps you merge the
content of selected layers into other layers.

To access the Merge Layer command:

• On the ribbon, click Home > Layers > Merge Layers.
• On the menu, click Format > Layer Tools > Merge Layers.
• Enter MERGELAYER in the command window.
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Reshaping Hatches

You can adjust the contour of hatches or gradient hatches.

When you select a hatch entity, the grips appear that help you adjust the shape. When
you hover over a grip, the shortcut menu appears with editing options.
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22
eDrawings

This chapter includes the following topics:

• Display Styles in Drawings
• Supported File Types
• eDrawings Performance Improvements

eDrawings® Professional is available in SOLIDWORKS® Professional and SOLIDWORKS Premium.

Display Styles in Drawings

If you saved a SOLIDWORKS drawing with specific display styles in drawing views,
eDrawings supports each display style for any .EDRW file that you save in eDrawings 2024
and later.

In the Heads-up View toolbar, eDrawings shows all display states if the drawing views
have shaded data: Shaded with Edges, Shaded, Hidden Lines Removed, Hidden
Lines Visible, and Wireframe. The Display Style tool is only available for drawings
with shaded data.

If you change the display style of a drawing view in eDrawings, only the selected view
updates with the new display style. All other views remain the same. However, if you
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change the display style when you have not selected a drawing view, all views change
to the selected display style.

If you rotate a drawing view, the display style is unaffected.

Supported File Types
eDrawings has updated the supported versions for several file types.

VersionFormat

Up to 2021ACIS (.sat, .sab)

Up to 2023Autodesk® Inventor® (.ipt, .iam)

Up to V5_V62023CATIA® V5 (.CATPart, .CATProduct)

Pro/Engineer 19.0 to Creo 9.0Creo® - Pro/Engineer® (.ASM, .NEU, .PRT,
.XAS, .XPR)

Up to v10.6JT (.jt)

NX1847 Series to NX2212NX™ (Unigraphics®) (.prt)

Up to 35.1Parasolid™ (.x_b, .x_t, .xmt, .xmt_txt)

V19 - 20, ST - ST10, 2023Solid Edge® (.asm, .par, .pwd, .psm)

eDrawings Performance Improvements
eDrawings performance is improved with various tools, rendering, printing, and file closure
times.

Performance improvements include:

• Measure tool. Up to 20 times faster when opening the Measure pane, entity selection,
and changing units.

• Markup tool. Up to 10 times faster when creating markups.
• Reset tool. Up to 1.5 times faster when resetting a model.
• Faster rendering and printing with software OpenGL.
• Faster times for closing files.
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23
SOLIDWORKS Flow Simulation

This chapter includes the following topics:

• Importing and Exporting Component Lists
• Mesh Generation
• Mesh Boolean Operations

SOLIDWORKS® Flow Simulation is a separately purchased product that you can use with
SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

For installation of SOLIDWORKS Flow Simulation, see Load SOLIDWORKS Flow Simulation
Modules.

Importing and Exporting Component Lists

In the Component Explorer dialog box, you can export component lists to a Microsoft®
Excel® spreadsheet, edit the properties, and import the component lists back.

By using a spreadsheet, you can manage component properties. You can edit:

• Materials
• Volume Sources
• Two-Resistor Components (library and power)
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• LEDs (library and current)

Mesh Generation

With the Smart Cell Cartesian mesh generator, you can generate meshes faster and with
smaller file sizes.

Speeds are 9-12 times faster on 32 cores for 10-20M cell models in Flow Simulation 2024
compared to 3-7 times faster in 2023. Meshing speed is about 2-3 times faster on 32
cores in 2024 because of scalability.

Mesh Boolean Operations
The Mesh Boolean Operation (MBO) handles complex and extremely bad geometry faster
and easier. When SOLIDWORKS cannot conduct Boolean operations successfully because
of bad geometry (such as bad topology with missing entities or self-intersecting faces),
you can use MBO.

MBO meshes bodies separately and then conducts Boolean operations on the meshed
bodies without using CAD Boolean operations.

This technology prepares and meshes even very bad models 5-15 times faster without
prior user adjustments or automatic model healing. You can use MBO with the CAD
Boolean diagnostic, combining the power of Mesh Boolean and the convenience of getting
additional information, such as a diagnostic of the fluid domain.

If the CAD Boolean diagnostic fails to detect the fluid domain, you can still mesh the
model with Mesh Boolean. In these cases, the Solver Monitor dialog box shows additional
subdomain diagnostics. You can specify how to handle the geometry (CAD Boolean,
Preprocessor Boolean (formerly called Improved Geometry Handling), or Mesh Boolean),
and you can turn off the CAD Boolean diagnostics.
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24
SOLIDWORKS Plastics

This chapter includes the following topics:

• Batch Manager
• Compare Results
• Cool Solver
• Hot and Cold Runners
• Inactivity Timeout for SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation,

and SOLIDWORKS Plastics
• Injection Location Advisor
• Materials with Pressure-Dependent Viscosity
• Material Database
• Mesh Enhancements

SOLIDWORKS® Plastics Standard, SOLIDWORKS Plastics Professional, and SOLIDWORKS
Plastics Premium are separately purchased products that you can use with SOLIDWORKS
Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

Batch Manager
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The Batch Manager PropertyManager is redesigned to improve usability.

• Rearrangement of the user interface elements in sections provides a streamlined
workflow for the Batch Manager.

• Ability to specity the maximum number of CPUs for an analysis task.
• Improved visibility for the simulation type assigned to an analysis task and for controls
to add, run, and pause an analysis task.
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Compare Results

You can display four different results plots from one study using split view panes.

To display multiple result plots after running a study:

Do one of the following:

• Click Compare Results (Plastics CommandManager).
• In a study's PlasticsManager tree, right-click Results and click Compare Results.

In the Compare Results PropertyManager, you have these options:
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DescriptionOption

Applies the same view orientation to all view panes.Synchronize
Views

Saves the split view of the multiple result plots to a .png image
format.

Save Image

Cool Solver

Solver options for ejection criteria enhance the performance of plastic injection simulations
for thermoplastic materials.

You can either specify the cooling time or let the cool solver estimate a cooling time based
on the following temperature ejection criteria for thermoplastic materials.

DescriptionOption

Specifies the percentage of the mold's
volume that needs to cool down below the
ejection temperature. The default is 90%.

Volume % frozen at ejection

Excludes the cooling state of the sprue and
runner segments from the ejection criteria.

Exclude Runner from Ejection
Temperature Criteria

It is common to reduce the overall
manufacturing time by ejecting the part

153

SOLIDWORKS Plastics



DescriptionOption

before the sprue and runner segments have
cooled completely.

Hot and Cold Runners

You can more easily assign hot or cold runner domains to components of a plastic injection
simulation.

To assign a runner domain type to a body listed under the Domains node, right-click the
body and click Hot Runner or Cold Runner.

Inactivity Timeout for SOLIDWORKS Simulation, SOLIDWORKS Flow
Simulation, and SOLIDWORKS Plastics

When you run SOLIDWORKS Simulation, Plastics, or Flow Simulation studies, the network
licenses remain active and do not time out. SOLIDWORKS holds the licenses during the
calculation process, which is considered an activity.

Inactivity periods, defined by a TIMEOUT option, only take effect after the studies finish
calculating.

Previously, licenses could time out while studies were still running. In situations with
limited licenses, another user in the network could take your licenses, leaving you without
licenses to resume an analysis after completing a study.
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Injection Location Advisor

The Injection Location Advisor can iteratively determine an optimal number of injection
locations (maximum of 10) to fill a cavity.

The default for Number of locations is Automatic, which activates the iterative approach
for finding an optimal number of injection locations. To specify a custom number of
injection locations, select User defined.

Materials with Pressure-Dependent Viscosity
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Fill and Pack simulations support materials with pressure-dependent viscosity.

Materials that have pressure-dependent viscosity are listed in the Plastics Materials

Database with an information icon .

Accounting for pressure-dependent viscosity is important for parts that contain long flow
lengths or very thin walls, or for cases where you need high injection pressures.

For more information, see Material Properties (Polymer, Mold, and Coolant Domains).

Material Database
The Plastics material database includes the latest data from the material manufacturers.

DescriptionMaterials

Added 417 new material grades from the
following material suppliers:
• CHIMEI: 42
• DuPont: 2
• EMS-GRIVORY: 4
• KRAIBURG TPE: 4
• LG Chem: 85
• MOCOM: 128
• ORLEN Unipetrol RPA: 20
• RadiciGroup High Performance Polymer:
2

• SABIC Specialties: 126
• Solvay Specialty Polymers: 1
• Trinseo: 3

New Materials

Updated 40 material grades with the latest
material property values provided by the
following material suppliers:
• Borealis: 1
• CHIMEI: 2
• EMS-GRIVORY: 10
• ORLEN Unipetrol RPA: 20
• SABIC Specialties: 7

Modified Materials

156

SOLIDWORKS Plastics



DescriptionMaterials

Removed 292 obsolete material grades from
the following material suppliers:
• 3M: 1
• ALBIS: 4
• Borealis: 1
• DuPont: 2
• DuPont Engineering Polymers: 2
• KRAIBURG TPE: 1
• LANXESS GmbH: 3
• LG Chemical: 56
• SABIC Specialties: 211
• Solvay Specialty Polymers: 11

Removed Materials

Mesh Enhancements

You can save the mesh settings of a study without creating a mesh. You can also preview
a surface mesh before creating a solid mesh.

The meshing options are available from the Solid Mesh - Tetrahedral, Solid Mesh -
Hexahedral, and Shell Mesh PropertyManagers.

DescriptionOption

You can save the mesh settings of a model (mesh size,
refinement method, and advanced mesh control) without

Save settings without
meshing

creating the mesh. When you run a study, the mesh settings
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DescriptionOption

are applied automatically to generate the mesh. In a study's
PlasticsManager tree, the icon next to Solid Mesh or
Shell Mesh indicates that you saved the mesh settings for
the model.

You can preview a surface mesh before creating a solid mesh
to check the mesh validity for a model.

Show preview
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25
Routing

This chapter includes the following topics:

• Naming Wires and Cables in the FeatureManager Design Tree
• Discrete Wires with Auto Route

Routing is available in SOLIDWORKS® Premium.

Naming Wires and Cables in the FeatureManager Design Tree

You can view the marks or names of 3D wires, cables, and their cores under Route Parts
in the FeatureManager® design tree for a routing assembly. The Electrical Attributes
PropertyManager automatically preassigns the marks or names.

This helps you correlate the 3D routes in the FeatureManager design tree with the marks
or names of the wires, cables, and their cores displayed on the schematic drawing.

The naming convention uses the following to uniquely identify different routes:

• Wire, cable, and cable core marks from the Electrical Attributes PropertyManager.
• Sequential numbers as suffixes (n). Where n is proportional to the number of splits
(with split route) and 1 (without split route).

• The directions (FROM/TO) that they connect to the components.
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For example, the above image shows the naming for a routing assembly with four wires
as follows:

• The three wires red, white, and yellow do not have Split Route applied and the naming
convention is:

Wire mark_1

For example, 20g_red_2_1

• The blue wire has a Split Route applied at two points with three split bodies created
and the naming convention is:

• For the two extreme ends connected to the components:

Wire Mark_FROM/TO_Component Mark

For example,

20g blue_1_FROM_Component1

20g blue_1_TO_Component2

• In-between cable bodies not connected to the components:

Wire Mark_n

For example,

20g blue_1_1

Discrete Wires with Auto Route

You can visualize each wire in a bundle distinctly in 3D and flatten them.

The Auto Route PropertyManager, Routing Options include:

• Merge wires into single route. Routes the selected wires along a single route.
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• Create a distinct route for each wire. Routes the selected wires as distinct routes.

You can edit discrete wires by:

• Adding a route to the bundle with Add Route to Discrete Bundle.
• Removing a route from the bundle with Remove Route from Discrete Bundle.
• Moving the bundle by dragging a spline point on the discrete wire.
• Merging two bundles with Merge Discrete Bundle.
• Splitting a single route segment from the bundle.
• Creating a single junction point for multiple discrete bundles coming out from the
connector or separate junction point for each discrete bundle.

• Routing the bundle through a clip by selecting one of its splines.
• Handling splices.
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26
SOLIDWORKS Toolbox

SOLIDWORKS® Toolbox is available in SOLIDWORKS Professional and SOLIDWORKS Premium.

Additional Toolbox Hardware
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More hardware is available in the ANSI Inch and Metric Toolbox libraries.

Additional HardwareAdditional FoldersStandard

• The Bolts and Screws > Self
Tapping Screws folder includes
a large hex head tapping screw.

• The Bolts and Screws >
Machine Screws folder includes
a large hex screw.

• The Washers folder includes:

• Circular Washers
• Square Beveled Washers

• The Nuts folder includes
subfolders for:

• Hex Nuts - Prevailing
Torque Nuts

• Wing Nuts

• The Pins folder includes
subfolders for:

• Clevis Pins
• Cotter Pins
• Grooved Pins
• Spring Pins
• Straight Pins
• Tapered Pins

ANSI Inch

Pins. Includes coiled spring pins.ANSI Metric

In the ANSI Inch standard, the hex head tapping screw_ai.SLDPRT in Bolts and
Screws > Self Tapping Screws > Hex Head Tapping Screw has been updated. If
you copy the updated file, you will lose any customization to the existing file.
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27
Design with SOLIDWORKS

This chapter includes the following topics:

• Creating a Single Physical Product
• Defining Rules for Updating Models to the 3DEXPERIENCE Platform

Creating a Single Physical Product

In the Design with SOLIDWORKS app, you can use Remove CAD Family to designate
a part or an assembly as a single physical product.

When you remove the CAD Family, the following changes occur:

• The part or assembly becomes a physical product.
• If the physical product is the active configuration, SOLIDWORKS uses the physical
product as the single physical product. If the representation is the active configuration,
SOLIDWORKS uses the parent physical product of the representation as the single
physical product.

• Other configurations change to representations of the single physical product.

• Inserts new physical product is disabled.
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• The ConfigurationManager title changes from Configurations: <CAD Family> to
Configurations.

When you have a single physical product, you can change the configuration used for the
physical product. Right-click a representation and click Convert to Physical Product
.

You can add a CAD Family object to a single physical product. Right-click the physical
product and click Create CAD Family.

You cannot use Convert to Physical Product on the following configurations:

• Speedpak configurations
• Exploded views
• Model Break views
• Defeature configurations
• Child configurations that required a parent configuration

To create a single physical product:

1. Open a model that has multiple physical products.
2. Right-click the CAD Family and click Remove CAD Family.

Defining Rules for Updating Models to the 3DEXPERIENCE Platform
You can use the 3DEXPERIENCE Integration Rules Editor to specify if a configuration is
mapped as a physical product or a representation when you update a model to the
3DEXPERIENCE platform.

When creating a sub-type rule, you specify document level criteria like filename, custom
properties, and weldments and sheet metal file types. You can use these rules to group
parts and assemblies.

For each sub-type rule, you define a configuration mapping rule to specify if the
configuration is a physical product or a representation.

To save a part configuration that is referenced by an assembly as a physical product, you
must create a sub-type rule. Previously, the part configuration was always saved as a
physical product.

New configurations are not created when you update a model.

3DEXPERIENCE Integration Rules Editor

You can create rules to specify which parts and assemblies to map to physical products
and representations when you update a model to the 3DEXPERIENCE platform.

You can save the integration rules to a designated folder.

To open the 3DEXPERIENCE Integration Rules Editor:

1. Tools > Options > System Options > 3DEXPERIENCE Integration.
2. Optional: Specify a folder for 3DEXPERIENCE Integration Rules Folder.
3. Click 3DEXPERIENCE Integration Rules Editor.
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Sub-Typing Rules

Incremental number for each sub-type.ID

Options for working with sub-type rules:

Adds a new row and opens the Sub-Type
Rule Definition dialog box.

Add

Opens the Sub-Type Rule Definition dialog
box where you can edit the rule.

Edit

Deletes the row.Delete

Action

Displays the sub-type name.Sub-Type Name

Displays the rule description.Sub-Type Rule
Description

Configuration Mapping Rules
These options display when you select a sub-type rule.

Specifies the configuration to use as the single physical
products.
• configuration named

You must enter a configuration name for this option.
And you must select either active configuration or
first configuration as a secondary configuration to
use.

• active configuration
• first configuration

Single physical product
with representations

Displays additional fields for determining which configurations
are mapped to physical products for the selected sub-type.

Multiple physical
product

Incremental number for each sub-type.ID
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Options for working with configuration mapping rules:

Adds a new row and opens the
Configuration Mapping Rule Definition
dialog box.

Add

Opens the Configuration Mapping Rule
Definition dialog box where you can edit
the rule.

Edit

Deletes the row.Delete

Action

Description of the configuration mapping rule.Configuration Mapping
Rule Description

Object type that configurations are mapped to.3DEXPERIENCE Object
Type

Specifies the action to take for configurations that are not
covered by the mapping rules.
Options for mapping:

• configuration named

You must enter a configuration name for this option.
And you must select either active configuration or
first configuration as a secondary configuration to
use.

• active configuration
• first configuration

Configurations not
included in the mapping
rules.

Sub-Type Rule Definition Dialog Box

You can create rules to group parts and assemblies before mapping the groups to physical
products and representations.

After creating these rules, you use the Configuration Mapping Rule Definition dialog box
to specify if the parts and assemblies are physical products or representations when you
update the model.

To open the Sub-Type Rule Definition dialog box:

1. Tools > Options > System Options > 3DEXPERIENCE Integration.
2. Click 3DEXPERIENCE Integration Rules Editor.

3. In 3DEXPERIENCE Integration Rules Editor, click Add .

Describes the sub-type rule.Sub-Type rule
description
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Specifies conditions for the rule.
Click Add to create a condition.

When you have multiple conditions, you can select All or Any.

Select an input:

Specifies an operator and a file name.Filename

Specifies a property name, an Evaluated
Value, an operator, and a value.

Custom Property

Options are Yes and No.

Available for parts.

Is Sheet Metal Part

Options are Yes and No.

Available for parts.

Is Weldment Part

Operators for Filename and Custom Property:

• contains
• does not contain
• is
• is not
• starts with
• ends with

Use Add and Delete to create and remove conditions.

If the following
condition is met

Specifies the sub-type name.Assign the
sub-type

Configuration-Mapping Rule Definition Dialog Box

You can define rules for mapping parts and assemblies to a physical product or a
representation.

To open the Configuration Mapping Rule Definition dialog box:

1. Tools > Options > System Options > 3DEXPERIENCE Integration.
2. Click 3DEXPERIENCE Integration Rules Editor.
3. In 3DEXPERIENCE Integration Rules Editor, if there are no rules defined, click

Add to add a sub-type rule. Close the Sub-Type Rule Description after creating
the rule.

4. Select a rule.
5. In 3DEXPERIENCE Integration Rules Editor, under Configuration Mapping

Rules, click Multiple physical product.
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Configuration Mapping Rule Definition

Describes the configuration mapping rule.Configuration Mapping
Rule Description

Specifies conditions for the rule.

Click Add to add a condition.

When you have multiple conditions, you can select All or
Any.

Select an input:

Specifies an operator and a
configuration name.

Configuration name

Specifies a property name, an
Evaluated Value, an operator, and
a value.

Configuration
Property

Specifies a BOM part numbering
option:

Configuration BOM
option

• Is Document Name
• Is Configuration Name
• Is User Specified

Options are Yes and No.Is active
configuration

Options are Yes and No.Is first configuration

The second list defines options for Configuration name,
Configuration Property, and Configuration BOM options.

Operators for Configuration name and Configuration
Property:

• contains
• does not contain
• is
• is not
• starts with
• ends with

Use Add and Delete to add and remove rows.

If the following
condition is met
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Maps the configurations to a Physical Product or a
Representation.

When you select Representation, the following options
display:

• configuration named

You must enter a configuration name for this option.
And you must select either active configuration or
first configuration as a secondary configuration to
use.

• active configuration
• first configuration

Map the configuration
to the 3DEXPERIENCE
object type
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Our 3DEXPERIENCE® platform powers our brand applications, serving 12 industries, and 
provides a rich portfolio of industry solution experiences.
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collaborative virtual environments to imagine sustainable innovations. By creating virtual twin experiences of the real world 
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management processes of their offer and thus have a meaningful impact to make the world more sustainable. The beauty 
of the Experience Economy is that it is a human-centered economy for the benefit of all –consumers, patients and citizens.

Dassault Systèmes brings value to more than 300,000 customers of all sizes, in all industries, in more than 150 countries. 
For more information, visit www.3ds.com.
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